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Chapter 1. About Bodno

Our primary objective at Bodno is to offer you the best identification solution.
We believe there’s a level of comfort knowing our clients on a 1st name basis.
Relationships matter... even in a world of social media & modern technology
and online shopping.

We are always pleased to hear from high-calibre individuals. Feel free to send
us an email or call at anytime.

1.1 Overview

Welcome to Bodno.
Bodno is more than an application...

Bodno is the ultimate tool for your professional ID card production in a user-
friendly way, designed to have the best performance with large databases with
and without photos. Bodno facilitates all type of tasks related to card production
such as the design, print and encode of ID cards.

Bodno is committed to a continuous software improvement by responding to the
clients' requests, keeping in touch with new technologies and anticipating the
needs of an ever-changing plastic card industry. Our worldwide staff is available
to assist you as needed through training, technical support, sales information or
through a wide range of services including full software customization, stand
alone projects or embedded projects.

Bodno allows you to create a card from scratch to production, without any
outsource program needed to deal with any aspect of the card creation
process, such as image treatment, card encoding or even the database
connection, because Bodno can connect to most any database.

Bodno's compatibility with Mac OS X Systems is the result of Bodno to offer a
flexible software solution, satisfying our customers needs, no matter what
operating system they are using.

Whether it's automating routine tasks or solving your toughest IT challenges,
Bodno delivers rapid value and simplifies the plastic card creation process
management, across physical, virtual and cloud environments. And that means
less chaos and stress for you, plus, big cost-savings for your organization.

© 2018 Bodno
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1.2 Features

= Software Box and Installation

Bodno comes with a full setup on an USB key that allows you to work on
Windows or Mac and carry your work with you. It also brings a Digital Manual in
PDF, card templates, clipart and shapes and allows a group and user log-in
management.

» Tools & Image

Bodno has in its tools a strong hold for its users, like 1D and 2D barcodes,
variable objects, templates, text setup, full image acquisition, face detection and
a complete built-in image editor. You also have access to a multi-layout design
option.

= User Interface

Bodno has five different views:

- the Welcome View where you define how you start or resume a previous card
creation process,

- the Users View where you can define groups and user log-in management,

- the Document View that gives you a complete overview of the document and at
the same time allows you to work directly on the card design,

- the Database View that is a full manipulation tool,

- and finally the encode view where you can setup your card encoding.

= Print

Bodno offers a front and back print option, SDK driver printing, Ethernet printer
support, overlay panel management and batch printing, print status and in some
editions conditional printing over database.

= Database

Bodno allows you to connect to any kind of database, such as CSV, Excel,
Access, among others. Bodno brings an internal database with photo
connection and a powerful database tool set where you can create and edit a
database, link an image to a field, browse, filter and find records, and
concatenation options.

» Encoding

This feature allows magnetic encoding, contact smartcard plugin, contact
smartcard encoding, contactless RFID encoding and internal / external RFID
encoding. Bodno also has internal / external RFID encoder support.

© 2018 Bodno
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= Miscellaneous
Bodno gives you free updates and automatic edition upgrades.

A user log that permits a step-by-step follow up of your work.
A programming script (JavaScript, based on ECMA Script Language

Specification).

© 2018 Bodno
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1.3 Security

Bodno has opted for a USB key solution that comes with a full setup.

Why? Because through this USB key you can work in any PC or Mac with the
advantage to carry your work with you and also because it makes easier to
recover your license online through ldentiSys.

This is a 4GB USB key, which means that a lot of work can be carried on it,
your card files, images, databases and anything elase you might need to carry

with you.

Currently thene is a Edition Bcense on your
compiiter, chck here to check for registensd upgrades for
this kcense
5N

[ | y — "

N
s b, |Bodno

Chack for Upgrades

W Advice: Always make a copy of your work. All data on your USB keys is
recoverable except your work. A USB key is a piece of hardware as reliable as
any other.

© 2018 Bodno
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Chapter 2. Installation and Support

Bodno is easy to install and customize.

2.1 Installing Bodno

For Windows and Mac installation, please follow the steps covered on the topics
Windows Installation and Mac OS X Installation.

© 2018 Bodno
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2.1.1 Windows Installation

Connect the provided USB key on one of your available USB ports. The AutoPlay will run
automatically and choose the 'Open Folder to view files' option.

Double-click on the Bodno executable file and the Installation Wizard will run. The Installation
Wizard is displayed where you can verify the Serial Number of your product and also select the
language to install. To proceed with the installation click the 'Next' button.

) Bodns 15112

Install

Shortcuts This wizard helps you to install Bodno

Finish

Please select language to install

Install or Evaluate
Select the installation folder. By default Bodno software is installed on the Programs Folder but you
can select another destination folder by selecting the 'Select Destination folder' option.

Check the option 'Install for all users' if you want other Windows users to also run Bodno software.
Click 'Next' to continue.

If you want to run the application without installing it please click 'Evaluate'.

Welcome

Shortcuts

Finish

Shortcuts

© 2018 Bodno
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Check the shortcuts that you want to create for easy access to the application, and if you wish to
open card files immediately with Bodno select the file associations checkbox. Click 'Next' to
continue.

L) Bodes 15018

Welcome

Install

Finish

Finish
Click 'Finish' to install Bodno software.

Welcome
Install Bodno 1.5.118

Shortcuts

© 2018 Bodno
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2.1.2 Mac OS X Installation_2

» |Install
Plug-in the USB key and double click on USB drive icon, then double-click on the Bodno.dmg file
and the end user license agreement appears, click 'Agree’ in order to proceed.

IMPORTANT - Read this
Licerde Agreement carefuily
betare clicking o the END=USER LICENSE AGREEMENT FOR
“Agres” buiton. By clickin
Aaree uttan Byelcking | COMPANY LICENSE”

g 15 b Boand by the
e ekt (e IMPORTANT = READ CAREFULLY

At

Please read the following license agreement. You
must agree to its terms before using this software.

This end-user license agreement ("EULAT is a legal
agreement between you either as an individual or a
single entity ("LICEMSEE™) and for
including computer software, electronic
documentation and printed materials ("SOFTWARET).
By downloading, installing, copying, or othenvise
using the SOFTWARE, you agree to be bound by the
terms of this agreement. If you do not agree to the

Print Save.,. Disagres Agree

Now drag and Drop the Bodno icon into the Applications folder alias to install.

800

> 2 itemns —_——

creativity and security
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2.2 Changing Language
You can change the language of the user interface at any time.

To change the language of the Bodno software, click "BOD" -> Language.
Choose the desired language from the list and restart the application to apply
the new language settings.

ﬂ Fle Edit View Tool Wndow

About K Arabic
fesky (Czech)
Clear Config Danish
USE Devices Deutsch (German)
v Englsh

Update Securty
Espafol (Spanish)
View Folders
Frangais (Francese)
Printer Drivers Indonesia {Indonesian)
Language b italiano (italian)

BELE (jJapanese)

¢ == (Korean)
Mededands (Dutch)

Mo nweguan

Paolska (Polish)
Portugués (Portuguese)
Pyccrun (Russian)

Slovendina (Slovak)

Swvenska (Swedish)

Tidng viét (Vietnamese)

R ER (Traditional Chinese)

© 2018 Bodno
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2.3 Updating Bodno

We advise to keep always your Bodno software up-to-date. To do so go to
and download the most recent version, according to your operating system.

4

Bodno

www.bodno.com

2.4 Bodno Support

Bodno's team treasures the relationship with our customers, keeping it as close
and personal as possible. We are committed to offer you the best support.

We offer support by email or remote sessions (Team Viewer):
1 Software@Bodno.com

© 2018 Bodno
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Chapter 3. Getting Started

€@ This chapter explains how to handle a document, model or template, how to
create or open an existing file and also how to recover a backup file.

Document - Contains all data related to your work, including the chosen model
or template, all objects, database connections, properties, and encoding
properties. In summary, all the properties involved in your card document
creation.

Model - Contains all the features and shape of your physical card. These
features are size and card type, if it is a basic card, contactless, magnetic or
smartcard. Please notice that the card settings depends on your chosen or
created model type. For instance, you can't access the chip encoding settings if
you've chosen or created a card without SmartCard capabilities..

Template - Is no more then a pre-made document layout used to create a new
document with a similar design, pattern, or style. This means that you can use
an existing template as it is or you can change it as you wish, creating a new
document or template from the opened template.

Backup - Bodno automatically generates a backup file of your document every
time its saved. This backup is created in a pre-defined folder (\My
Cards\Backups') with the document name and date/time creation..

© This document can be recovered any time you need.
Example: documentname(yyyymmddThhmmss).cardBackup

© 2018 Bodno
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3.1 - Welcome View
* Welcome View

The welcome view is your starting point when it comes to working with Bodno.
Here you can create new card models, open existing card models or previously
made templates, or even create a basic card with a step by step guide.

Here you can also access the Production Mode (available on Bodno SILVER),
Users View (only on Bodno PLATINUM Edition or higher) or simply quit
Bodno.

Hart using rrc card and creste your new cand

To return to the Welcome View at any time:
@ Click Window menu » Welcome View

¥ You can get help in different ways. Choosing "Help" from the Help menu or
context-sensitive help that is always available by pressing the F1 with the cursor
located on the element on which you want help. In addition, many dialog boxes
contain a Help button.

© 2018 Bodno
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3.1.1 -BOD Menu

The top menu bar, gives you access to the "BOD" menu.
Here you can find information related to Bodno.

About Y

Clear Config
USE Devices
Update Security
View Folders
Printer Drivers

Language 4

E About Bodno - Show your release, edition and serial number.

E Clear Config - Sets Bodno all settings to default, including print settings, object settings and
work space.

E USB Devices - Show all information about your Bodno USB key, the drive ID and the serial
number, if this information is not shown it means that your USB key has not been recognized by the

system, please check it.

E Bodno License - Shows information about your Bodno USB key and allows online upgrade.

Currently there is a Edition license on your
computer, click here to check for registered upgrades for
this license

SN

K. Bodno

[
l — | .

Check for Upgrades

Close

E View Folders - Show information about Bodno working folders. If you don't find a file or don't
know where Bodno keeps it's folders like cliparts, backups, shapes, etc, you can check on this list

its location.

© 2018 Bodno
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£ Bodno Folders

Bodno Folders,

BACKGROUNDS
BACKUFS
CLIPART
COMPONENTS
DATABASE
DOCUMENTS
DOWNLOADEDTEMPLATES
MODELS
MYMODELS
MYSCRIFTS
MYTEMFLATES
FICTURES
FRINT
PRINTSETTINGS
SHAPES
TEMFLATES

E:/Bodno/ClipartFiles/Backgrounds o
C:/Users/rmess/Documents/My Cards/Backups
E:/Bodno/ClipartFiles/Clipart

C:/Program Files (x86)/Bodno/COMPONENTS
C:/ProgramData/Bodno/DATABASE
C:/Users/rmess/Documents/My Cards
C:/Users/rmess/Documents/My Cards/Downloaded Templates
E:/Bodno/CardFiles/Models

C:/Users/rmess/Documents/My Cards/My Models
C:/Users/rmess/Documents/My Cards/My Scripts
C:/Users/rmess/Documents/My Cards/My Templates
C:/Users/Public/Pictures/Bodno
C:/ProgramData/Bodno/PRINT
C:/ProgramData/Bodno/PRINT SETTINGS
E:/Bodno/ClipartFiles/Shapes

E:/Bodno/CardFiles/Templates

Close

E Printer Drivers - Shows information about the printers and drivers installed on your computer
and if you click on View All Supported Bodno Printers' you have access to a list of compatible

encoding printers.

E Language - Allows you to choose the language in which Bodno is presented.

© 2018 Bodno
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Chapter 3. Getting Started n

The first step to printing cards is creating your own card.

@ To create new card, in the Welcome View @ Click Create New Card
button

Or © Click File menu » New (CTRL+N)

CP BEEN Window Help

3 New Ctri+N
£ Open Template Ctrl4+Shift+0

£ Open ctrl4+0

Exit

Then you can choose the card type that you intend to use from our list of
supported card types:

© 2018 Bodno
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Card Types 23 Card Types | All card Types -

—
ﬂ)) MIFARE ﬂ)) . E— kll;‘ﬂ
——
Crcd)
. GENERIC J ﬂ)) . S—

‘.I]}) DESFIRE - o J| —

HICD LOCO 1)) miFare HICO ) miFare

O Partrait ok || close

After selecting the card type, the Bodno Design View will automatically open,
giving you access to all the tools you need to add and edit content to your new

card.

ESESDE @=8T QAQ DHHd OHBD B %

-l ‘

. ,

-

e 3

o9 -

:

my | opr ]
:

®| ccess control card C—

@ Sonia

i Davolio

; Sales Representative
E Home Phone:(206)555-9857
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3.3 - Open Your Own Card Documents

@ In Bodno there are two kinds of files, the ones you create, called card
documents and the ones created by Bodno designated by backup files.

To better organize your documents, in the "Open Card" window, you find
"Bodno Favorites" with two folders - "My Recent Cards" and "My Cards". Or
alternatively you may locate your file in another folder in "My Computer".

You can sort the way how the cards are displayed. You may sort them by
Name, Name Descending, Modification Time, Modification Time Descending,
File Size and File Size Descending.

£ Open Card ... 7 *

Explorer| .. Sort Cards By [ veme

w L Bodno Favorites
My Recent Cards
My Cards
B My Computer

0K Close

O in the lower right corner you can find the information about how many readable
documents are currently present in the selected folder, or the name for the current
selected card document.
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3.3.1 - Open an Existing Card Document
© You can open an existing card document to edit, change or even print
again.

The first step will be to locate the card document that you wish to open. In order
to do so, please click the 'Open' button on the "Welcome View" or use the

'Open' option from the 'File' menu.

@ Click File » Open (CTRL+ SHIFT + O) » Explorer and locate your card
with extension .card

£ OpenCard ...

Explorer| .. Sort Cards By | tame

~ EJ Bodno Favorites
My Recent Cards
My Cards
B my Computer

oK Close

@ Click OK.

Organize = Mew folder ==l ':EZ'

=
Mame Date modified Type Size

Backups File folder

My Models File folder
W my_card.card

File name: 'my_card.card - |card(*.card]

Open - Cancel
|

4 Your file should have the extension .card

O Sclect the file extension in the corresponding Combo Box, otherwise your file
will not be listed. To proceed "Open".
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3.3.2 - Recover Your Card Documents From Backups

O A backup is a file that Bodno automatically creates every time you save a
document in an internal or external drive. The file will be saved with a date and
time reference to make it easier to detect the last backup made. With this you
have the assurance that you have a copy of your document in a specific
date/time, in the backups folder.

Before opening your backup, you should know where Bodno created the
backup folder during installation. To check the path:

@ Click BOD » View Folders

£ Bodno Folders ? *

Bodno Folders,

BACKGROUMDS E:/Bodno/ClipartFiles/Backgrounds o

BACKUPS C:/Users/rmess/Documents/My Cards/Backups

CLIPART E:/Bodno/ClipartFiles/Clipart

COMPONENTS C:/Program Files (x86)/Bodno/COMPONENTS

DATABASE C:/ProgramData/Bodno/DATABASE

DOCUMENTS C:/Users/rmess/Documents/My Cards

DOWMNLOADEDTEMPLATES C:/Users/rmess/Documents/My Cards/Downloaded Templates

MODELS E:/Bodno/CardFiles/Models

MYMODELS C:/Users/rmess/Documents/My Cards/My Models

MYSCRIPTS C:/Users/rmess/Documents/My Cards/My Scripts

MYTEMPLATES C:/Users/rmess/Documents/My Cards/My Templates

PICTURES C:fUsers/Public/Pictures/Bodno

PRINT C:/ProgramData/Bodno/PRINT

PRINTSETTINGS C:/ProgramData/Bodno/PRINTSETTINGS

SHAPES E:/Bodno/ClipartFiles/Shapes

TEMPLATES E:/Bodno/CardFiles/Templates E
Close

@ Now that you know where your backups are stored (.../users/
.../Documents/Backups ), you can easily locate the backup document that you
need to recover.

Q Click File » Open » Explorer » Bodno Favorites » My Cards » [ =221 »
Backups and select your backup document in the folder "Backups"

© Remember that your backup has a
'filename(savedate Tsavetime).cardBackup' filename convention.
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£ Open Card ... ? X

Explorer| .. _ Sort Cards By [ neme

v K1 Bodno Favorites
My Recent Cards
My Cards
B My Computer

| 0K | Close

Q Click OK.

Organize = New folder ==« IZ@I
MName : Date modified Type Size
| daniel(20130111T124839).cardBackup 08-01-2013 16:21 Backup 94 KB
| My_Model(20130110T215857).cardBackup ~ 10-01-2013 21:54 Backup 3KB
| My_Model(20130110T220933).cardBackup ~ 10-01-2013 21:58 Backup 6 KB
| My_Model(20130110T221047).cardBackup ~ 10-01-2015 22:08 Backup TKB
| My_Model(20130110T221135).cardBackup ~ 10-01-2015 22:10 Backup &8 KB
| My_Model(20130110T221327).cardBackup ~ 10-01-2015 22:11 Backup &8 KB
| My_Model(20130110T221350).cardBackup ~ 10-01-2015 22:13 Backup &8 KB
| My_Model(20130110T221406).cardBackup ~ 10-01-2015 22:13 Backup &8 KB
| MyModel(20130110T170818).cardBackup 10-01-2013 17:06 Backup 83 KB
| MyModel(20130110T172244).cardBackup 10-01-2013 17:08 Backup 5KB
File name:  My_Model(20130110T215857).carc ~ ’cardBackup (*.cardBackup) v]
[ Open |vl ’ Cancel ]

¢ Your file should have the extension .cardBackup

© Now all you have to do is to save your document with another name and with
.card extension.

© Select the correct file extension in the corresponding Combo Box, otherwise
your file will no be listed.
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3.4 - Using Templates

O A template is a collection of styles that control the layout and appearance of
a card document. You can quickly create your card document using one of our
many templates.

Bodno provides these templates organized in categories, such as Test and
Diagnostic; Sports; Shopping; Schools; Loyalty; Clubs & Resorts; Business;
Activities and Access Control.

But if for some reason these categories don't fit your needs, you can always
create new ones, just go to My Templates directory and once there create a
new folder and Bodno will assume that folder to be a template category.

The Templates cover a wide range of graphics and variable field types, all of
them fully editable. These professional templates are part of your Bodno
software. Your Bodno USB dongle also contains additional templates.

Template Types 29 Card Templates Al Card Templates |- |

Your Logo

Yourlggo,

npatrum _."

O Closae
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3.4.1 - Create from Existing Template

@ To create a document from a template, in Welcome View Q Click
Templates

or © Click File menu » Open Template (CTRL+ SHIFT + O)

ZCl Window Help

= New Ctri+N
Bl Open Template Ctrd+Shift+0
= Open Ctrl+0

Exit

[t cat menstasatit e

I

0m W m A S

W In the dialog box, search through the available templates.
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@ You can create a card based on a template and then modify the document
without affecting the original template

i
T
ol

q

Davolio

Sales Representative

ODRHBEEN ®ERESE= w001 | [

Home Phone:(206)555-9857

™ By making changes to the background, images, text, and orientation card.
You can create a new design to suit your needs. You can also modify any card
object in your document.

@ All you have to do now is to save your new card document.

3.4.2 - Create Your Own Templates

O If the preset templates do not meet your requirements, you can create a
template based on your own styles.

To create your own template, start by creating a new card and chose a model
type that fits your need. For instance, if you chose a contactless model, the
result will be a template based on your contactless, but with your own design.

Card Types 4 Card Types Common Card Types

1]}} GEMERIC ﬂ]) MIFARE

ok Clase
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Q Click 'OK:". If you want to continue. Otherwise click 'Close’ to revert to the
previous window.

O A template may include any object type, variable field or text that can be
edited and modified at any time. Make all the changes you want on your
template and then save it with '.cardTemplate' file extension, in the appropriate

folder in Bodno (.../My Cards/My Templatesl/...).

© Click File » Save or Save as and create your file.

File pame: your_card_temnplate.cardTemplate

Save as type: ?_'I_'EMPLATES i*.card'l'emi.)late] =

DOCUMENTS (*.card
[ Cuiom I | e anld

% Browse Folders | 3i0nE1S (" cardModel)

¢ Your file should have the extension .cardTemplate
© You can edit your template at any time.

Q Click File » Open » Explorer (=

K Open Card ...

Explorer| .. Sort Cards By [rame

w LI Bodno Favorites
My Recent Cards
My Cards
B My Computer

OK l Close

Organize « Mew folder Bz > [ (7]

Name i Date madified Type Size

_ | your_card_template.cardTemplate 3KB

File name: your_card_template.cardTemplate - lcardTempIate (*.cardTemplate) VI

(oo D) [ o ]

© 2018 Bodno



Chapter 3. Getting Started

O Select the file extension ".cardTemplate” in the corresponding Combo Box,
otherwise the template files will not be listed.

O After you have completed your template edition © click Save and your old
template will be replaced with the new modifications.

3.5 - Using Models

@ Bodno allows you to create a document in two different ways, by using an
existing model or by creating your own card model.

The first one only requires you to choose one of the many different types of
models that Bodno has at your disposal. Like mentioned before, you have four
major kinds of card models: basic, contactless, contact smart card and
magnetic, and each type can have different settings like sizes, different kinds of
magnetic strips and so on, all listed on Bodno model type.

But if you have a specific type of card model that is not listed, Bodno allows
you to create it and that's the other way to create a document, using a new card
model.

© Note that whatever model you choose, it will restrict access to further settings and
properties, like referred before. If you open a "Contact Smart Card", the result will be a
model of your "Contact Smart Card", where you can only edit Smart Card Settings, and it
will not allow you to access, for instance, RFID settings.
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3.5.1 - Create from Existing Model
@ This topic guides you on how to create a new document using an existing
model. You can start a creation procedure by clicking on the create button on
the "Welcome View".

© 'Welcome View' » 'Click Create"'
N @ =
PZhL B 2n =]

or @ ‘Click File' menu » 'New' (CTRL+ N)

* BEER window Help

O New ctri+N
g3 Open Template  Ctr4-Shift+0
B Open Ctril+0

Exit

© Then choose the type of model you want. The model types are organized in
5 groups:

M Basic - have no contacts, no microprocessors or internal memory. Simple
piece of plastic that you can print on front and back side.

[M Common - are the most common types of card models, used by the vast
majority of users.

M Magnetic - this model type allows you to encode the magnetic stripe through
Bodno. This means that you can print and encode your card at the same time
or use an external encoder. These cards may contain secondary technology,
like RFID technology.

M Contactless - any pocket-sized card with embedded integrated circuits that
can process and store data, and communicate with a terminal via radio waves.
This type of card model allows you to encode through Bodno. By using
JavaScript language, you can program your card and perform the read and
write operation on the card. This also means that you can print and encode your
card at the same time or use an external encoder.
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M Mifare - this card model, when chosen, allows you to read or write the
several sectors of your card. By using JavaScript language you can connect
the sectors to database fields and update them automatically or simply enter
data through keyboard input, therefore you can print and encode at the same
time. These cards may contain secondary technology, like Magnetic stripes.

M Contact - a smart card, chip card, or integrated circuit card (ICC) is any
pocket-sized card with embedded integrated circuits. In Bodno you have four
types of card models, 12C, JCOP (Java Card), SLE4442 and generic. This type
of card model allows you to encode through Bodno. By using JavaScript
language, you can program your card and perform read and write operation on
the card. This also means that you can print and encode your card at the same
time or use an external encoder.

M Unusual - set of models used by a small number of users. Model types
developed for specific projects are now included in this group.

M User Models - if you have any models in folder "My Models", they will
become available in this group.

Card Types 23 Card Types Al Card Typs

Iﬂ) MIFARE

. GEMERIC

iﬂ) DESFIRE

HICO

oK Close

After you have chosen the model type, @ ‘Click OK' and you will be able to

start working on your new card. Or © ‘Click Close' if you want to revert to the
previous window.
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3.5.2 - Create Your Own Model

@ To create a document using a new model, you have to start by creating the
model. This will be your starting point to customize your own document.

Card Types 4 Card Types Comman Card Types |

l}:?) GEMERIC J’]]) MIFARE

Your next step is to save that same model with the extension '.cardModel' and
save it in the Bodno folder called "Documents/My Models" in order to be
identified as a model.

O It is important that you save your file in the folder "My Models", to be
displayed in the category "My Models" in "Select model type".

@ Click File » Save or Save as and create your file as the example below, in

your folder "Documents” (To see the folder location, please click on menu o
BOD » View Folders)

File pame: your_card_model.cardMadel -

Save o5 type: MODELS [".cardModel) =]

= Browse Folders - [ Fave ] A

4 Your file must be saved with the extension .cardModel

€ At this point, you've created your new model "yourdoc.cardModel." The next
step will be to locate your file and open it.

Q Click File » Open » Explorer » Bodno Favorites » My Cards » [ ===
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£ OpenCard .. ? x

Explorer .. Sort Cards By [ rame

~ EJ Bodno Favorites
My Recent Cards
My Cards
B My Computer

OK | Close

Qrganize * Mew folder = -~ [ &

Mame . Date modified Type e

=) ;,-nu:_dard_m:dei.:ardh‘ladel cardPresse Madel 3 KB
File name: ynur_urd_model.:ardMade‘ - :'l:-lﬂ‘.'MDd'ﬂ {".cardModel) "T

O Select the file extension in the corresponding combo box, otherwise your file
will not be listed.

@ After opening the model, you can customize the dimensions and corners
radius. On your right on the properties tabs you will find a tab named "Layout"
where you can change the card dimensions and corners radius,

Wwidth  |85.725 mm
Height |53.975 mm
RX 2 mm

RY 2 mm

You can also change the orientation of your card by Q clicking on File menu

» Configure Print and In "Print Layout" © Click Orientation and select your
card orientation. The card orientation can be changed at any time, but this will
be your card default orientation.

© 2018 Bodno



Chapter 3. Getting Started n

COnentation -1_ Landscape "u

‘C[iandscape

Portrait

¥ You can add images, text or other elements to customize the thumbnail that
you will see in the preview area.

.
Your Logo:

My Model_85X55mm

O The last step is to save the model that you've just created. From now on the
new model will be displayed in the Create Document Dialog Box, under the

category "My Models".

© Click File » Save (CTRL+ SHIFT + S)

Card Types 1 Card Types iy Madels

© Please note that cardModels can't be printed, they have to be saved as
*.card before you can print.

© 2018 Bodno
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Chapter 4. Design

© The definition of design is the creation of a plan or convention for the
construction of an object (as in architectural blueprints, engineering drawing,
business process, circuit diagrams and sewing patterns). Design has different
connotations in different fields. In some cases the direct construction of an
object (as in pottery, engineering, management, cowboy coding and graphic
design) is also considered to be design.

In Bodno you can design and build a layout. To accomplish this, Bodno
provides the user with specific tools and objects, allowing you to build your
layout according to your imagination, capabilities and needs.

©® As you know, when you design you create a file, called document, this
document keeps inside all the settings you will use on your creation.

4.1 - Workspace

@ In Bodno you can customize your working area as you wish. You can
reposition the menu bars or you can view or hide properties areas.

© On the View menu you have a set of options that allows you to change your
working scenario.

ToolBars

M Here you can select all the dockbars that should be available in the working
space.
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U= Tool Database Window Help

— -
B Card Front P :ﬁ‘ W}'
1

(L=
= (Card Back

B Database View TR TRy i ows g e a

= Encode View

v Object Properties

v Document Toolbar

Zoom Bl v Views ToolBar
i ] v ZFoom Toolbar

Metrics b

v Database ToolBar
Rulers 3

v Design ToolBar
Grid | 9
Workspace Color P Use defaults

Metrics
M Allows you to define the measurement unit that you wish to work with.

Tool Database Window Help

— o]
B Card Front P E.‘@j

1 = Card Back
E Database View ; ; ;
= Encode View

v Object Properties

ToolBars k

foom b

Millimetres

Rulers 3
Grid b

Vorkspace Color

Rulers

M Visible - Show or hide the rules in the card design area.

© 2018 Bodno



Chapter 4. Design “

[ Selected Items - Shows or hides the area occupied by selected items on

top of the card design rulers Set

Tool Database Window Help
P — ._@j

B Card Front

5

= Card Back

IE Database View

= Encode View

v Object Properties

ToolBars 3
Zoom b
Metrics [ g

v Visible
Grid

v Selected Items
Workspace Color

v Page guides

Grid

M Visible - Set the card visible or hidden

step or free move

[ Snap to Grid - Allows you to move and/or position the objects on a grid unit
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Tool Database Window Help

=] — 1
Card Front h L -ﬁh

L~
1 = Card Back
E Database View ; ; ;

= Encode View

)

v (Object Properties

ToolBars b
Zoom b
Metrics b
Rulers k

v Visible

I'I 4 } .
Workspace Color o SR G

Workspace Color
M Allows you to chose the workspace background color

Tool Database Window Help

m Card Front —
ard Fron P =35 m

= Card Back

& Database View

= Encode View

v Object Properties

ToolBars r

Zoom 3

Metrics 13

Rulers L4

Grid [

l"":S_'_:" ’

Workspace Color Black
Blue

v Bodno

Gray
Green
White
Custom
Choose Custom Color

© Switch between front or back card side.
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© Switch to Database View.

o He yew Datsbase frdow
| & = - - - 7] ¥ F1 15 Fi
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Database
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]
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E 5 Callghan Laurs Insicky
@ 5 Dadaworth A Sales
] 2 Hallatum Akt Busar,
11 mn Ervth Ty Mal T
[ v
Solect Al|  Solect Fene, | Rggie Selection
Datalais Recond
Database C:PregramDeta) [DATABASESntsmalDatabase mdh Tible:Employse
Record 1 of 15
-
Emglayos Phata
Suptresor i
5
Last Mams
Dianka e
¥
0 1 "

© Switch to Encoding View.
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| W He Yew Database Wndow Help
= L% - COR-a i i
C - 1OR .“ﬂ.:l.ﬂa.;x.}.} FORSHE
| S — ... — o

Encode Model

1 »
| ——r—— &
2
Caontact encoders | No contact encoders found | S %
tunictian GETUIDY) k]
= {
| i phease write here serial number jawa Script to read sedal
L E

1 RESPONSE = cand APEILNOwB0, dutA, OofiE, O TE 0 ;

i #RES POMSE length==84)

oy

Il retmRESPONSE. substring{ 152,15 2+81); ook -

Ml
}

card.waikForPresent(™);

legi "MEDA TYPE:“+card. mediaTme);
leg("MEDLA, 5N =+ Ccard maedialD K

2
b
2
=]

N TP:SAVE SERIAL NUMBER ON DATABASE RECORD

i 1) chaote the database Dackbar,

i 2} drag the held where you want to save the serial number and
drop over the ling bolow

| W=z cmentRecord. = card medialDcurentRecord savel):

|8
N TP UPDATE CARD FELD

s & 1) choose the preview Docidar, |
Contact | Output o

4.2 - Document Properties

©® When you open the document view, the first thing you will see is the work
space and on the right side the basic properties of your card document.
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M Backgrounds - Each layout can have a unique background. You can
access Bodno backgrounds library using the Backgrounds Tab. To apply a
background just select it from the list and the background will be applied
immediately to your card layout. You can also set the background using an
image object.

M Clipart - You can access it using the Clipart Tab. They can be used as an
image object, part of your card layout creation, or as a background. Please
note that you can only change the background color of the object.

M Layouts - Like we said before in this manual, when you design a card, you
are building a layout and in Bodno, a document can have as many layouts as
you want. The Layouts Tab is our way to offer you a quick way to manage all
the possible layouts on your card document.

M Script - The Script Tab allows you to write your own script commands,
based on the ECMEASCcript language specifications. This is a way to extend the
already large number of features that Bodno offers you. It also allows you to
interact with external software, using the results to apply on your document. You
have three different kind of script boards, one for each object, one for the card
document and one for encoding, three different ways to expand Bodno
capabilities.
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4.2.1 - Background

@ An image to be applied as the background of your card. Bodno offers you
many background images that can be used from landscape cards to portrait

cards.
: : [ . ;
All classes *_J S | All classes *
L - 3 - J
B ) =
5 :
@
h—

: m Backgraund |

B
a=
A

i

EEN el .

61 Backgrounds found, 0 folders remaining 11 Backgrounds found, 0 folders remaining

E

© Background images are divided into classes that are accessible through the
background combo box.

[ All classes | »

(Al classes is
Technology u
Transportations
Unsorted
Geography
Road

Shopping
Celebration
Animals
Architecture
Buildings

Cats

Dags

Clean

Clown
Computers
Couple

Cyeling -
Ice

lce cream |

© It is possible to add a folder with images to use as a background, in the
Background Tab @Al classes select @#User Folder.
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All claszes v

L
#User Folder

Clipart . Background

Layouts

Script

262 Backgrounds found, 0 folders remaining

O And select through the Explorer Browser the Folder with the images to use as

Background.
Organize - Mew folder e ﬁl l
Name 3 Date medified Type Size
. Backups 21-06-2013 12:10 File falder
. Downloaded Templates 21-06-2013 12:10 File folder
. My Models 21-06-2013 12:10 File folder
1. Wiy Project Backgrounds 27-09-2013 1.2:36 File folder
. My Seripts 26-06-20132 13:05 File falder
. My Templates 21-06-2013 12:10 File folder

Folder: My Project Backgrounds

SelectFolder | | Caned |

@ It's also possible to use your own image as the card background.

Add an image object to your layout, then right click on the object and chose 'Set
as a Background' option, like shown on the picture below.
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+r Fa Edit View Tool Database Windww Help

HEAEE ASEE AAR B L LD

All tlasses
—

e ).
.

L : Copy ctd+c

o : Delete Del

ﬂ I_ Duplicate

L) — m send T Front

L & send T Back

a : Export Image

ﬁ [ Set As Background ] e
=

Fit to Card

Backgrounds found, & folders remaining

S

If you want to change or edit the background, right click on the card and
choose @ 'Edit background'.

HEEE keeal AARA B

Select All

Duplicate
Paste

{  Edit Background

‘PkEME KK BBER

1063 x 709 - 100.0

The Image Editor will open and from there you can edit the background image.

To commit changes, @ click on the 'Save Changes' button, otherwise press
'Cancel’ to continue.
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4.2.2 - Clipart

@ Clipart images are pre-made images that can be used to help on the layout
creation. Bodno offers you several.

all classes A

S[a[ |

O el
._rﬁ@

=1~1@ N
QDA & .

1282 Images found, 0 folders remaining

Background

Clipart

Layouts

O They are divided into classes. All you have to do is select one class from the
dropdown combo box.

Al classes v ]

Eﬂ classes I+
[Symbals i
|meats_and_eggs
| thanksgiving
| Mautical
| Celebration
| Clock
| Countries
|Flags
el
| Geography
| Bread
Burguer
Food
Hot Dog
Perpherals
| Storage
| vegetables
| dairy
| Dalphin
| Durk
| Elephant
| Grass Hopper

:Gull |

Background

Clipart

Layouts

@ Select the image from the clipart list, and drag it to the card design area. The
selected image will be used as an image object that you can modify.
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4.2.3 - Layouts

@ The Layout Tab allows you to define properties, settings and conditions for
the use of the layouts. This feature allows you to use the same card document
on as many layouts as you need and conditionally print the ones you want.

Clipart T Background

Layout 2

Add Copy Delete
] Aauto Select based on database condition

| Aadd || copy || Delete |

[ Employee ID ¥ I

| Is Equal Ir)

[ Aute select on card design

Secript IDaraba se Find T Database

[ Name - You can give a name to your layout.

M Add - You can add a new empty layout

[M Copy - Creates a new layout based on the current selected layout.

[ Delete - Delete the selected layout.

M Auto Select Based on Database Condition - When checked it allows
access to a condition box, where you can define fields and conditions for every
layout. Remember that these conditions are restricted to the selected layout.

O After you enable the checkbox, the first drop list shows all the available fields
from the connected database. You can apply conditions based on the available
fields as you can see below.
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Employee ID

|Emiployieli DR s
Supenisor ID
Last Mame
First Mame
Pasition
girth Date
Hire Date

Add Copy Delete Home Fhone

7] Aute Select based on database condition Extension
Photo

Notes
Englayma @ Reports To

15 Equal . Salary
55N

(1234 i ,'l Emergency Contact Arst Name
[0 Auto select on card design Emergency Contact Last Mame
Emergency Contact Felationship
|Emergency Contact Phone

Layout 2

[1s Equal

[1s Equal ]

Is Mot Equal
Cantains .
Mot Contains
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M Is Equal - Link the chosen layout to all records with the selected field equal
to the input value.

M Is Not Equal - Link the chosen layout to all records with the selected field
different from the input value.

M Contains - Link the chosen layout, based on the field value, to all the
records that contains the input value.

M Not Contains -Link the chosen layout, based on the field value, to all the
records that do not contain the input value.

M Is Null - Link the chosen layout to all records where the selected field is a
null value.

[ Is Not Null - Link the chosen layout to all records where the selected field is
not a null value.

O After you have chosen one condition, you can set it to match any string, like

shown on previous picture . however please notice that the condition is not
case sensitive.

O If the record doesn't comply to any condition it will assume the layout of the
previous record.

@ What benefits may be obtained from using multiple layouts? To explain it, we
will show you a sample case using one of the predefined templates available with
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Bodno.

€ Now let's imagine that you have three different departments in your
company, Sales, Marketing and another one that for this example purpose we
will call it General, but only one database and you need distinguish them visually
for faster identification. The process is simple:

© After opening one of our predefined templates, a connection to an internal
database will be made.
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It's time to start working on the card layouts. Now click on the Layout Tab.
As you can see you already have one layout, from Bodno business card.

Now we will add two new layouts in order to have three different layouts for
sales, marketing and general departments.

To start, change one of the layout's name to Marketing and then click on the
auto select checkbox to set the conditions.

On the database field, choose the field that will define the layout selection, in this
case will be the Position field.

Then in the next drop list set the condition for the chosen field, on our example
we set it to 'Contains’'.
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And on the text box below add a value for the condition. In this case it is the
department's name, remember that this is not case sensitive.

Finally, enable the 'Auto select' checkbox. This option allows you to see the card
layout that depends on the condition field type when scrolling through the
database records.

= ) =
el 7] Auto Select based on database condition

' Position b4 J
((Containa =
Marketing ]

[ Auto select on card design

yourlogo

Sonia
Davolio

o
=
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T
w
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[
i
[
]

Now choose a distinguishing color for the card that in our example is what will
define visually the different departments.
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Now add a new layout for Sales and General departments. Click on the copy
button twice.

As you see it copies our previous card to the new layout. All we need to do now
is the same procedure we made for the Marketing layout.

Define database settings for each new layout.
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Now use the navigation buttons and start scrolling through the database records.

As you can see, now the setup of the card is finished, connected to an excel
database and with three different layouts to define the different departments.

© This is an example, you can choose as many layouts as you want and set

your own conditions.
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4.2.4 - Script

@ There are two kinds of scripts in Bodno, one for each object and one for the
document. In this chapter we focus on the card document script.

This is an advanced user area, where you can program actions and procedures
in ECMEASCcript language in order to define settings or update your object.

When Document Loaded

[When Document Loaded
Eefore Print

Before Prant Recaord
After Print

After Print Record

Audit Successful Print
Database Connected
Database Disconnacted
Print Dialog

Print Copies

Ecrrpl:l. Output o 'E_}

@ This drop-menu allows you to define when the actions or procedures must
take place.

| script |[EEE

@ Andin the space below you can write your lines of code.

® To see the log of your program output, change tab below.
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4.3 - Document Objects

@ These objects are the most important features in your card document
creation process. There are two major types of objects, static and dynamic.

The first class refers to objects that will never change along the creation or data
input process, like backgrounds and shapes, for instance.

The dynamic objects can be text objects linked to database (changing while
browsing through several records), print counters or date/time objects.

The objects can be placed throughout the card space, in the front and back
side. And can be arranged as you wish in order to meet your creation needs.

There are also a set of specific settings to each object that you can use
according to your own specifications, like color, size, source, among many
others.

4.3.1 -Line

@ This object is a simple straight line, but still has some features that you can
setup. You can choose between five different kinds of lines and a custom one

w

[L More Calors...

™ Solid Line: Is a plain line.

M Dash Line: Dashes separated by a few pixels.
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M Dot Line: Dots separated by a few pixels.
¥ DashDot Line: Alternate dots and dashes.
¥ DashDotDot Line: One dash, two dots, one dash, two dots.

[M The Custom Line is a line that you can define as you wish. By clicking on
the 'advance' button you can set additional parameters like offset and pattern.

@ Line width: pre-defined options vary between 0.01" to 0.25", but you can
type a customized value.

@ vou can, also, change the color by clicking in one of the colored squares,
acquire any color you have on your screen using the dropper or use the
advance color settings by clicking on the 'More Colors' button.

Q By clicking on the 'advance’ button you have access to settings that allows
you to change the shape of your line. All you have to do is to write the command
on the line like shown below.

O (h

/RoundCap [SquareCap

Pen Parameters:

jSquareCap
fSquareCap [FlatCap foundCap ol Cancel

M SquareCap: A square line end that covers the end point and extends
beyond it by half the line width.

M FlatCap: A square line end that does not cover the end point of the line.
[M RoundCap: A rounded line end.

Qi you right click on the object a pop-up menu is shown allowing you to:

Ctri+C
el
ctrd+D

copy
Delete

Duplicate

B 5&nd To Front

W Send To Back

At to Card
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[M Copy - Click on the copy option or use the shortcut (CTRL+ C) to copy the
object to the clipboard.

M Delete - Deletes the selected object.
M Duplicate - Creates an exact copy of the object on the work space.

M Send to Front - Send the object to the front of all objects on the work
space.

M Raise - Send the object to a higher position on the work space.
M Lower - Send the object to a lower position on the work space.

M Send to Back - Send the object to the back of all objects on the work space.
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4.3.2 - Rectangle

@ This object can be either a rectangle or a square, depending only on the
side measures.

Qif you right click on the object a pop-up menu is shown allowing you to:

Copy Ctr+C
Delete Del
Duplicate Ctrd+D

B Send ™ Front
W Send To Back

Fit to Card

[ Copy - Click on the copy option or use the shortcut (CTRL+ C) to copy the
object to the clipboard.

[ Delete - Deletes the selected object.
[ Duplicate - Creates an exact copy of the object on the work space.

M Send to Front - Send the object to the front of all objects on the work
space.

M Raise - Send the object to a higher position on the work space.
M Lower - Send the object to a lower position on the work space
[M Send to Back - Send the object to the back of all objects on the work space.
® You can also setup a number of properties and settings on the properties

tab, on the right of your screen. All properties and settings will be
addressed further on this manual.
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4.3.3 - Circle

@ This object can be either a circle or an ellipse. By moving the delimitation
lines you can change the appearance of the object.

Qif you right click on the object a pop-up menu is shown allowing you to:

Copy Ctri+C
Delate Del
Duplicate  Ctrl4D

W Send To Front
M| Send T Back

U il At to Card

M Copy - Click on the copy option or use the shortcut (CTRL+ C) to copy the
object to the clipboard.

[ Delete - Deletes the selected object.
[ Duplicate - Creates an exact copy of the object on the work space.

M Send to Front - Send the object to the front of all objects on the work
space.

M Raise - Send the object to a higher position on the work space.
M Lower - Send the object to a lower position on the work space.
[M Send to Back - Send the object to the back of all objects on the work space.
® You can also setup a number of properties and settings on the properties

tab, on the right of your screen. All properties and settings will be
addressed further on this manual.
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4.3.4 - Shape

@ This object can assume many different shapes. On the Shape Tab you have
a dropdown menu with several categories of shapes. Inside each there are
several shapes that you can add to your card.

Copy Ctrl$C

Delete Dl

R
B
O AL

Duplicate  Ctrd+D

B Send T Front
B Send T Back

At to Card

S I o =

®
A
%
N/

’

S v [ reston L oo | i | ostion | e

(

RG2GHOF " &5 >

© You can change the color by clicking in one of the colored squares, acquire
any color you have on your screen using the dropper or use the advance color
settings by click on the 'More Colors' button.

Qif you right click on the object a pop-up menu is shown allowing you to:

[M Copy - Click on the copy option or use the shortcut (CTRL+ C) to copy the
object to the clipboard.

M Delete - Deletes the selected object.
M Duplicate - Creates an exact copy of the object on the work space.

M Send to Front - Send the object to the front of all objects on the work
space.

M Raise - Send the object to a higher position on the work space.
M Lower - Send the object to a lower position on the work space.

M Send to Back - Send the object to the back of all objects on the work space.
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© You can also setup a number of properties and settings on the properties
tab, on the right of your screen. All properties and settings will be
addressed further on this manual.
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4.3.5 -Text

@ The text object allows you to add text to your card document. After
positioning the text on the card design area double-click on it to start typing your
text. The default text format is a text box.

1
-
I
]
-
r
i

| (T

‘ | #

Please enter text
Your Text]

Close

© There are three kinds of text objects: alphanumeric, numeric and Lists.

With the alphanumeric text objects, you can use a single line text or a text box,
that allows you to write more then one line of text.

The numeric type is divided in value, integer value and date/time.
There is also Lists and Database Lists, that are no more than a small list with two

fields, one works as an index and the other as the data that the object should
display.

Qif you right click on the object a pop-up menu is shown allowing you to:

: ¥ Copy Ctrl+C

F— —. '
Delete De
Duplicate Ctrl+D

W Send To Front

& Send T Back

Ft to Card

M Copy - Click on the copy option or use the shortcut (CTRL+ C) to copy the
object to the clipboard.
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[ Delete - Deletes the selected object.
[ Duplicate - Creates an exact copy of the object on the work space.

M Send to Front - Send the object to the front of all objects on the work
space.

M Raise - Send the object to a higher position on the work space.
M Lower - Send the object to a lower position on the work space.
[M Send to Back - Send the object to the back of all objects on the work space.
© You can also setup a number of properties and settings on the properties

tab, on the right of your screen. All properties and settings will be
addressed further on this manual.
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4.3.6 - Print Counter

@ The Print Counter object allows you to set a counter and print it on the card.

You can set the update of the object to manual or automatic and interact with a
database field.

O It also allows you to define the counter numeric format and values.

N —

00000001+ 00000001[ corr  cuise
. H ; bl Delete Dl

i""""""""""'+ o REEEAERNT Duplicate Ctrl+D

A

m Send To Front
B Send To Back

At to Card

Qif you right click on the object a pop-up menu is shown allowing you to:

[M Copy - Click on the copy option or use the shortcut (CTRL+ C) to copy the
object to the clipboard.

M Delete - Deletes the selected object.
M Duplicate - Creates an exact copy of the object on the work space.

M Send to Front - Send the object to the front of all objects on the work
space.

M Raise - Send the object to a higher position on the work space.
M Lower - Send the object to a lower position on the work space.
M Send to Back - Send the object to the back of all objects on the work space.
© You can also setup a number of properties and settings on the properties

tab, on the right of your screen. All properties and settings will be
addressed further on this manual.
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4.3.7 - Print Date

@ The Print Date object allows you to print on the card the current printing date
and/or time.

You can set the update of the object to manual or automatic and interact with a
database field.

O It also allows you to define the date and time format.

Delete Del

A ﬁ Duplicatea  Ctr4+D

m Send T Front

q 52013 54) » 06-05-2013 Copy Ctrl+C
i b

W Send To Back

Fit to Card

Qif you right click on the object a pop-up menu is shown allowing you to:

[M Copy - Click on the copy option or use the shortcut (CTRL+ C) to copy the
object to the clipboard.

M Delete - Deletes the selected object.
M Duplicate - Creates an exact copy of the object on the work space.

M Send to Front - Send the object to the front of all objects on the work
space.

M Raise - Send the object to a higher position on the work space.
M Lower - Send the object to a lower position on the work space.
M Send to Back - Send the object to the back of all objects on the work space.

© You can also setup a number of properties and settings on the properties
tab, on the right of your screen. All properties and settings will be
addressed further on this manual.
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4.3.8 -1D Barcode

@ This object allows you to create a barcode. A barcode is an optical machine-
readable representation of data relating to the object to which it is attached.

There are many different barcode types, Code 128, EAN-8, UPC among many
others. Each one with different features and settings.

You can setup to see only the bars or complement it with readable data.

© You can also connect the object to a database field to become a dynamic
readable source.

= =

: e T y Duphcate Ctr+D

AR . S - — (- z

+ W Send T Back
IH ll‘ I“ I‘l ‘H |‘ |‘ |“ —

0 ]

Qif you right click on the object a pop-up menu is shown allowing you to:

(]} m Send T Front

M Copy - Click on the copy option or use the shortcut (CTRL+ C) to copy the
object to the clipboard.

[ Delete - Deletes the selected object.
[ Duplicate - Creates an exact copy of the object on the work space.

M Send to Front - Send the object to the front of all objects on the work
space.

M Raise - Send the object to a higher position on the work space.
M Lower - Send the object to a lower position on the work space.

M Send to Back - Send the object to the back of all objects on the work space.
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© You can also setup a number of properties and settings on the properties
tab, on the right of your screen. All properties and settings will be
addressed further on this manual.
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4.3.9 -2D Barcode

@ This object allows you to create a 2D barcode. A 2D barcode is also an
optical machine-readable representation of data relating to the object to which it
is attached, evolved from the 1D barcode into rectangles, dots, hexagons and
other geometric patterns in two dimensions (2D). Although 2D systems use a
variety of symbols, they are generally referred to as barcodes as well.

There are many different 2D barcodes types, PDF417, Datamatrix, QR-Code
and others. Each one with different characteristics.

© You can also connect the object to a database field to become a dynamic
readable source.

0|

Copy Ctrl+C
Delete Del

Duplicate Ctd+D

m Send To Front

& Send T Back

Fit to Card

© Please be aware that this object is only supported from GOLD edition
onwards.

Qi you right click on the object a pop-up menu is shown allowing you to:

[M Copy - Click on the copy option or use the shortcut (CTRL+ C) to copy the
object to the clipboard.

M Delete - Deletes the selected object.
M Duplicate - Creates an exact copy of the object on the work space.

M Send to Front - Send the object to the front of all objects on the work
space.

M Raise - Send the object to a higher position on the work space.
M Lower - Send the object to a lower position on the work space.

M Send to Back - Send the object to the back of all objects on the work space.
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© You can also setup a number of properties and settings on the properties
tab, on the right of your screen. All properties and settings will be
addressed further on this manual.
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4.3.10 - Image

@ This object is a very important one, not only because it allows you to add and
work an image on your card, but also allows you to transform that image into
your card background.

It can be added to your card from any source available like a scan device,
camera, disc or cloud and allows any kind of image, jpg, png and others.

With Bodno you can transform that image as you want, changing color, light,
size and many other settings.

© Making it your card background is easy, right click on the image and chose
'Set as Background' and your picture is adapted to your card size.

& o[

Copy Ctrd+C

- Delete De
Duplicate Ctri+D

m Send To Front
s W send To Back
1

Export Image
Set As Background

At to Card

Qif you right click on the object a pop-up menu is shown allowing you to:

M Copy - Click on the copy option or use the shortcut (CTRL+ C) to copy the
object to the clipboard.

M Delete - Deletes the selected object.
M Duplicate - Creates an exact copy of the object on the work space.

M Send to Front - Send the object to the front of all objects on the work
space.

M Raise - Send the object to a higher position on the work space.
M Lower - Send the object to a lower position on the work space.

[M Send to Back - Send the object to the back of all objects on the work space.
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M Export Image - Allows you to export the image as a file to anywhere on your
computer.

M Set As Background - Set the image as the background of your layout.

© You can also setup a number of properties and settings on the properties
tab, on the right of your screen. All properties and settings will be

addressed further on this manual.
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4.3.11 - Signature

© This object allows you to add a Signature on the card.

A Signature can be added from Signature Pad devices recognized by Bodno,
which are the WinTab, Wacom Bamboo & Topaz:

- SigLite LCD 1x5 - T-L460-HSB-R and T-LBK460-HSB-R

- SigLite LCD 4x3 - T-LBK750-BHSB-R

- SignatureGem LCD 1x5 - T-L462-HSB-R and T-LBK462-HSB-R

- SignatureGem LCD 4x3 - T-LBK755-BHSB-R and T-LBK755SE-BHSB-R
- SignatureGem LCD 4x5 — T-LBK766-BHSB-R

The Signature can also be saved to a Database as an image.

Copy Ctri+C
Delete Del
Duplicate Ctri+D

m Send To Front

| Send To Back
Export Image

Set As Background

At to Card
‘ ' e

Qif you right click on the object a pop-up menu is shown allowing you to:

M Copy - Click on the copy option or use the shortcut (CTRL+ C) to copy the
object to the clipboard.

™ Delete - Deletes the selected object.
[ Duplicate - Creates an exact copy of the object on the work space.

M Send to Front - Send the object to the front of all objects on the work
space.

[M Raise - Send the object to a higher position on the work space.
M Lower - Send the object to a lower position on the work space.

[M Send to Back - Send the object to the back of all objects on the work space.
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M Export Image - Allows you to export the image as a file to anywhere on your
computer.

M Set As Background - Set the image as the background of your layout.

© You can also setup a number of properties and settings on the properties
tab, on the right of your screen. All properties and settings will be

addressed further on this manual.
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4.4 - Object Properties

@ Bodno has a properties space, shown on the right side of your screen and
you can display it as a set of tabs or as a tree or accordion set, as pictured
below. To change, just right click on an empty space on the tab and check one
of the options.

|.I£em

lkem |
o

ITEM_34DF91B4
e n]
Group ITEM_34DF91B4
Group
Options
O Design not allowed
: Options
L) Do ok Brin [ Design not allowed
Opacity [] Do Mot Print

! Opacity
4 y/ 0
ﬁ : Position
v Tabs
Clipping

Treea

Fotation

Outline

=
=
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o
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o
=
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i=
=
5]
=
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w

These tabs change depending on the object we are dealing with on the working
area and as you will see further on in this manual.

@ Script, Layouts, Clipart and Background are the four basic tabs already
referred on the 'Card Document Settings' chapter. These tabs are shown after
you chose your card model and are previously referred to in this manual.

© 2018 Bodno



n Bodno Manual

441 -ltem

© The Item tab allows you to define the ID, Group and visibility of an object.

Item

18]
ITEM_32DF91B4

Group

Options
] Design not allowed
] Do Mot Print

Cpacity

Clipping

M Object ID - Defining the object ID not only helps you organizing data on
your document, but also gives you an easier object identification and helps you
on encoding operations.

When manipulating a database you can use an ID to identify objects that will
help you while programming a script.

The options settings allows you to:

M Design Not Allowed - Check the 'Design not allowed' box protecting the
object from being changed, but only the graphical appearance and drag & drop
position, not the content. This option is applied to all objects but background.

M Print - Lets you set if an item should be printed (Yes), if an item should not
be printed (No), if it should only be printed when it contains data (Only when
has data), or if it should only be printed when the data currently displayed in
the item is valid for the type of item (Only when has valid data).

[ Opacity - You can also define the opacity level of the object by scroliing the
opacity button, from 100%, the default position to 0%.

4 Encoding - For items that hold data to be encoded, like magnetic tracks, this
option allows you to manually set if the date should be encoded (Yes), shouldn't
be encoded (No) or to only encode if the item currently has data when being
encoded (Only when has data).
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4.4.2 - Position

© In this tab you can set the position manually or check the real-time position
when moving and/or resizing the object directly in the card design area.

The same properties apply to the objects dimensions, allowing you to manually
change the width and height of the object with a higher precision level.

Item

i Position |
x 9.019 mm
¥ [9.283 mm

Width  |31.015 mm
Height [29.112 mm

Clipping
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4.4.3 - Shape

@ This option allows you to change the visual shape properties of an object with
different formats: circle, rectangle, rounded rectangle or a customizable one (by
setting up the number of sides according to your needs).

Shape

] | |l g

X Radius:

|4 mm
¥ Radius:
4 mm

Alignment

It's like hiding the image behind a layer with a hole in the middle, and the shape
of that hole define the visible part of our image, as shown below. For instance if
you chose a circle shape the area of the photo that is sitting directly above the
circle content area now remains completely visible.

e - = =2 = :
Original Clipping Effect Format After Clipping Effect

O To define the clipping area and format all you have to do is drag the image
boundaries.
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4 4.4 - Rotation

@ In this tab you can rotate or define a rotation angle to your object... Or you
can select more than one object and apply a rotation to all the selected objects
at the same time.

Clipping

[F!ntati:m

@ Bodno has quick rotation buttons for the most common rotations, 0, 90, 180
and 270 degrees rotation. You may also rotate the object in increments and /or
decrements of 45 degrees (also available using the shortcut ‘Backspace’).

@i you wish to apply a more specific rotation use the edit box available for
those situations

@ Or turn the round button to the desired angle, updating at the same time the
angle box value.

© All these changes are seen in real-time on the object.
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4.4.5 - Outline

@ Outline allows you to chose between five different types of predefined lines
and a custom one.

| Outline I
LP(DUT Text.. E | Dash Dot === o= ——— \,.
SIio iewanhmon @)
_ | EyE -
|
/ I i |
\ I ol
- -
-
Yo
i{ f.. H‘,E
B F3 |More Colors...
Advanced...
o

M Solid Line: Is a plain line.

M Dash Line: Dashes separated by a few pixels.

M Dot Line: Dots separated by a few pixels.

™ DashDot Line: Alternate dots and dashes.

M DashDotDot Llne: One dash, two dots, one dash, two dots.

M The Custom Line is a line that you can define as you wish and if click on
the advance button besides the normal advanced parameters you are allowed to

set offset and pattern parameters.

@ Line width is one of the settings that you can change from 0.1mm to 10mm
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9 You can also change the color by clicking in one of the colored squares,
acquire any color you have on your screen using the dropper or use the
advance color settings by clicking on the 'More Colors' button.

Q Clicking on the 'advance' button you have access to a number of settings
that allows you to change the shape of your line. All you have to do is to write
the command on the line like shown below.

O C_

/RoundCap [SquareCap

Pen Farameters:

iSquareCapl
fSquareCap (FlatCap FoundCap oK P

M SquareCap: A square line end that covers the end point and extends
beyond it by half the line width.

M FlatCap: A square line end that does not cover the end point of the line.
M RoundCap: A rounded line end.

4.4.6 - Fill

O Define the fill color you want to see applied on your object, in case of lines,
rectangles or circles it will change the color of the object, on all other cases it
will change the background color.
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oo |

Cutline

(6l

| solid Al v

F
z] More Colors...|

[ No fill: No color is applied to the object. This option is extremely handy when
placing Text over other objects.

™ Solid Fill: Fill the area with only one color and you can define the color
using the standard palette, the dropper or using the advanced palette within the
"More Colors" button.

M Gradient Fill: Allows you to pick a second color and make a gradient effect
with both colors and define both colors using standard palette, the dropper or
clicking in "More Colors" button using the advanced palette.

M Dropper: In case of using the dropper you can select any color, even
outside the program window, like shown on the first picture below. After that the
color is applied to the object and added to the color palette as you can see on
the second picture.
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Scnipk !

[M More Colors: Gives you access to an advanced color palette.

™ Basic Palette Color Theme: To chose a theme for your basic palette color
use the drop menu like shown on the picture below and the theme is

automatically applied to the basic palette color.
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| 90% Black

Apples
Bananas

Black Body
camouflage
Candy
Christrmas
Coral reef
Desart
Earthtones
Easter
Eyes
@ Feminine
Fire
Flaghfenes
Midnight
Mountain
Mud
—hongil—
| |Rainbow
TrFoses
— Sarnid
Shades of Autumn

O In this example choosing the Rainbow option will apply to the basic color
palette only colors related with the Rainbow theme.

M Unusual Color: In case you want to add an unusual color, you have two
ways to do it, you can drag the crosshair through the panel or input directly the
color values on the boxes.

After that, the new color is added to the basic color palette.

4.4.7 -Font

@ When you select the 'Font' tab, a number of tools allows you to define the
font of your object.
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Your Text... !

Ftl nt

Font Famul;\-I
Anal v |
Pmnt Slze =
150pt = O Auto . :Tl" Arla[ Black
Color i"Pr Arial Narrow
.msaauamz . -] iTr Arial Rounded MT Bold
Wﬁ;e |Tf' Arial Unicode MS
‘E . |Tr Amo Pro
[ Arno Pro Caption

[Hr Arno Pro Display

(B Arno Pro Light Display

:TT Arno Pro Smbd

T Arno Pro Smbd Caption
I Arno Pro Smbd Display
T AUdimat

O word wrap .
[ Render as HTML .

@ First you have the 'Font Family' where you can chose the font type, all fonts
that you have in Windows or on Mac OSx are displayed here.

® Point Size - Allows you to define the font size, if you check on the checkbox
the size is determined by the space available between boundaries, to change
just drag and drop the selection handles.

@ Color - Chose the font color.

4 Typeface allows you to define more font settings that affect the whole
Textbox, like:

BIU

® vou can also wrap the sentence on your object by checking the ‘Word
Wrap' checkbox.
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ooeer Your |
i Tex :
,out """ e .- :rext;" ______ *

( O werd wrap ) (_ [Z] word wrap )

® with 'Render as HTML' checked, you can use some HTML codes in your
text to change the "Typeface' in parts of it, instead of the whole Textbox.

Please enter text

<u=This is a</u> <i=Textbox=</i=
<b>'Render as HTML'</b> <p=Test

Close

0o

M Text between <u> </u> will be Underlined.
M Text between <i> </i> will be in /talic.

M Text between <b> </b> will be in Bold.

M The <p> starts a new paragraph.
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4.4.8 - Barcode

@ The bar code properties allows you to define some properties depending on
the type of barcode you want to use. There are two major types of barcodes the
1D and 2D, illustrated below.

Fill

Barcode l

BT g ya-pTr f
Code 128
! T Barcode color
: [rsic2ssesi -
B i Module width
Auto
Bearer bar
[@ [ﬁ:-.q IEI Mo bearer bar
B-E:- FEFE.H] Elea.rer width
[ 5 R
Cuaet Zane
0 0 mm
Human readable
i ==
Font
Normal
CheckDigit

MNone

Source

Let's start by making a general introduction, to the most common properties of
barcodes, referenced in Bodno:

M Type: Chose the type of barcode you wish to use, keeping in mind that in
some cases your choice may change other properties range of values.

M Color: Define your barcode color.

M Human Readable: Defines if the readable data, alphanumeric characters, is
imprinted or not (only 1D barcode).

M Font: Defines the font of the readable data (only 1D barcode).

@ Other properties and definitions are specific to each different type of
barcode, will be addressed further on this manual.
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4.4.9 - Image

@ You can acquire images from any source available; from disk, from a
database, from a camera or even from a scanner.

119

o

le

ip
(8

"t

&

8

g

v

EFEEEBR-om) B g*

© After you select an image and apply it to your working area, you have
access to a new tab, the image tab. On this tab you can change a set of
properties as:

M Keep Ratio: Allows you to adapt the image to your object boundaries or
keep the image ratio.

[ Reinforce Black: This option forces the usage of Resin K on the black in
the image.

M Flip Horizontal: This option reverses the active object horizontally, that is,
from left to right. It leaves the dimensions of the object and the pixel information
unchanged. It looks as if the image has been reflected along the central vertical
axis of the object.

™ Flip Vertical: This option reverses the active object vertically, that is, from
top to bottom. It leaves the dimensions of the object and the pixel information
unchanged. It looks as if the image has been reflected along the central
horizontal axis of the object.

M Grayscale: Applies grayscale on the image in which the value of each pixel
is a single sample, that is, it carries only intensity information. Images of this
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sort, are composed exclusively of shades of gray, varying from black at the
weakest intensity to white at the strongest.

™ Chromakey Effect: Turn the chromakey effect on and off in which a color
range in the top layer is made transparent, revealing another image behind.

[M Color: Allows you to choose the color range on which the effect will act. Use
the dropper to chose any color on the image.

M Tolerance Level - Allows you to change the tolerance level of the effect. The
bigger the tolerance, the larger the range of colors affected by the effect.

M Effect area - Select the area of the image affected by the effect, if all image
or only on the frame.

Q if you double click on the image the Image Editor opens with more edition
tools.
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4410 - Source

©® The Source Tab allows you to define the origin of the object and
parameterize that same object. In Bodno you have two major object classes, the

images and the text objects.

Image

|Source |
From Dick f""*}-\
Title _ » i
| E
Please browse image | From Disk r|
Source ﬁ'ﬂmgﬁk“-
5 | Frorm Camera of Scanner
e | Fromn Signature Pad
Updated | Erom Database
: {Iterm Link
When ltem Double-Clicked —r—

Save with document
s

Format
Image Free format

Face Detection
Mo
Open image editor

Only when errer

©® On text objects and barcodes, the source can be a print counter, a print
date, a keyboard input, database or item link.

On image objects and signatures, the source can be the disk, a camera or
scanner, the image editor, a database field or an item link.

On the next chapters we will show you how to use them and how to
define them, in sum: how easy it is to manipulate any of the sources or its
properties.
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©® When you have a text or barcode object selected you can use the Source
Tab to set the input options for the object.

©® On this tab you will define what kind of object it is, how it is updated, under
what condition it will be updated, when it will be updated and the final result.

Source |

l Keyboard Input

Print Counter
Prirt Date

ard

Database
ke Link

I

|,
Il

ard Input r ]

Please enter barcode data
Updated
When tem Double-Clhicked - ]

Save with document
Mo - ]
Data Type

Text Line v ] (s

Concatenation
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4.410.1.1 4.4.10.1.1 - Print Counter

@ This feature allows you to add a print counter to your card. It can be updated
automatically and saved with your card file, thus keeping the counter status. You
can also define values, justify and set the number of digits of the counter as
explained further on this manual.

When a text object is selected you can go to the Source Tab and, on the drop
down menu on top, choose the Print Counter option or click on the 'Print
Counter' button on the design toolbar.

© You can update your counter in five different situations:

Print Counter

Updated
'L Before Print Before Print Card
when Item Double-Clicked b g2
When Load Document __________ ¥o~ v by ST
[Before Print ] -
Before Print Card ' =
After Print Card |

Item

Mirmmum Value

1

E Maxmum Value
£ 99995999
=
=l Restart Value
1
Increment Value
1
Current Value

1
Justified with zeros

es

Mumber of digits
8
Font auto adjust

MNever

[ Concatenation |

S (R o ] 0 o | i

™ When Item Clicked - When you double-click the object it will update the
counter according to all the settings.

[M When Load Document - Every time the card document is opened.

M Before Print - Count the number of times you send a print order and update
the counter before the printing procedure.
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[ Before Print Card - Count the number of cards you're going to print and
update the counter before each card is printed.

M After Print Card - Count the number of cards you printed and update the
counter after printing each card.

© And set the following properties:

[ Save with Document - Save the settings and counters with the document so
you don't lose any data.

M Minimum Value - Defines the counter minimum value in case of negative
incrementation.

M Maximum Value - Defines the counter maximum value in case of positive
incrementation.

M Restart Value - Is the value assumed by the counter when it reaches the
maximum or minimum values. (Min Value < Restart Value < Max Value)

™ Increment Value - Defines the incrementation value, it can be positive or
negative.

M Current Value - Shows the current value.
™ Justified with Zeros - Justify with zeros until the desired number of digits.

M Number of Digits - Defines the number of digits used in the counter, you
can justify with zeros.

M Font Auto Adjust - Automatically adjust the font size, but only if font point
size is set to auto.

M Concatenation - Allows you to add a prefix or suffix to your counter value. If
you don't want these to be printed check the Ignore on print check box.
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4.410.1.2 4.4.10.1.2 - Print Date

@ This feature allows you to add a date object to your card. It can be updated
automatically and saved with your card file, thus keeping the date status. You
can also format the date and time as explained further on this manual.

When a text object is selected you can go to the Source Tab and, on the drop
down menu on top, choose the Print Date option or click on the ‘Print Date'

button on the design toolbar.

tem

Before Print

When tern Dauble-Clickead
When Load Document

[Before Print

Before Print Card

=
o
E
Er
ﬁ

[Ha[-19 Source

[ script |

Prnt Date

Updated
Bafore Print Card

pave with document

Yes
Format
dd-MM-yyyy (hhzmm) |+ | [
Font auto adjust
Mewver
:'ﬁinc atenation '_
Increment Value
1
Current Value

1
Justified with zeros

Tes

Mumber of digits
4
Font auto adjust

MNewver

[Concatenation |

© You can update your date/time in four different situations.

™ When Item Clicked - When you double-click the object it will update the

date and time.

M When Load Document - Every time you open the document it will

automatically update the date object.
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M Before Print - Update the counter before the printing procedure starts and
all the cards are printed with the same date and time.

M Before Print Card - Update date and time before printing each card.
© And set the following properties:

M Save with Document - Save the settings and date/time of the last printing
procedure with the document so you don't lose any data.

M Format - You can format the date using one of the preset formats available
thru the drop down menu or by creating your own format by clicking on the
pointed button and then write it according with the legend below.

=) Date and Time format

dd-MM-yyyy (hh:mm)

i MM- hih:

Srrdl i iy dd-MM-yyyy (hh:mm)
yyyy-MMM-dd | oK Cancel
yyyy-MMMM-dd '
Wﬁ::ﬁ%d d tha day as number without a leading zero (1 to 31
¥y i dd  the day a3 rumber with a leading zero (01 to 31}
Yy MM rmdd ddd the abbrevated localized day name (8.9, ™on’ to
dd-MM-yyyy dddd the long locakzed day name [e.q. ‘Menday to “Sun
del-MMM M the month as number without a leading zero (1-12

it WYYy M tha month as number with a leading zero (01-12)
dd-MMMM-yyyy MMM the abbreviated locabzed month name (e.q. Jan' &

MMM the long localized month name (e.g. Januany to D

dd MMy
dd.ﬂ'ﬂMH vy the year 5% two degpt rumbeir (00-55)
hk IYYYy vyyy the year as four digt number

Hylys]

Tirmsa
hh;mm:ss h this hour without a leadeng zéno (0 to 23 6r 1 to 12 if AM,
_hh:mm:ss:zzzz hh  the hourwith a leading zero (00 to 23 or 01 to 12 if AMA
[dd-MM-yyy (hhimm] | m the minute n!huu-l'. a:ﬂdqu zero [0 to 54)
dd-MM-yyyy (hh:mm:ss) mmm  the minute vath a leading zero (00 to 58)
5 the second withaut a leading zeno (0 to 59)

ddm me l:hh:rnm,'l 55 the second with a leading zera (60 to 33)
ddMMpyyyy (hh:mm:ss) z the milkseconds without leading zerces (0 to 990)

zzz  the millseconds with leading zerces (000 to 955)
AP wmd AMPM display AP vwall be replaced by enher “AM* or
ap  wuse amjpen drsplay ap wll be replaced by either "am® or

M Font Auto Adjust - Automatically adjust the font size, but only if font point
size is auto.

M Concatenation - Allows you to add a prefix or a suffix to your date and it
can be printable, to do that just check on the check-box.

4.410.1.3 4.4.10.1.3 - Keyboard Input

@ This setting allows you add an object to your card that is updated by
keyboard input. It can be updated automatically, saved with your card file. You
can also choose the data type like explained further on this manual.

When a text object is selected, you can go to the Source Tab and on the
dropdown menu, on top, chose Keyboard Input option.
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M Title - You can give a name to your object, it will make it easier for further
identification.

® You can update the object in six different situations.

Fill

Source |

_xe_yhnard Input _ TextBox Properties
Title Columns (g0
. Please enter text
Before Print Card o e
Updated

When Item Double-Clis ,i'|
On Custom View Before Print Card

On Edit View '\—'-—f,
When Load Document ave with document

Before Print

Before Print Card KF. Mo
[After Print Card f i Diota Bpe

Ny .
|RextBox N\ Text Box

| Text Line

-

Text Font auto adjust
EVE'UJ&BDK B : .. | Tdlmwe Propeties
Mewver
Integer Value | J e
[ | ] I Mask
%f:ﬁ | Concatenation id::-n H:s
wabdation Fules
Date and Time
b N ox ] cuns
| Database list

[ When Item Clicked - When you double-click on top of the object it will open
an input window to update.

M On EditView - This setting, when chosen, allows you add a new field to a
small internal database, as you'll see further on this manual.

M When Load Document - When the card document is loaded this object is
updated.

M Before Print - After the print order and before start printing, it will open an
input data window in order to allow you to update the object, after that it will not
be update again until next print order, on the example below was date field.

M Before Print Card - Before print each card, it will open an input data
window in order to allow you to update the object, on the example below was

date field.

M After Print Card - After print each card, it will open an input window in
order to allow you to update the object for the next card, on the example below

was date field.
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Print Record 1 of all

Please enter text
2000/01/01 =]

Cancel | |Continue

M Save with Document Save on your card document the last object update.

M Data Type On this setting you can define what kind of data your object can
hold.

[M Text Line - Allows you to input text information in one line.

TextLine Properties

Data Length o
Input Mask

Validation Rules

oK Cancel

M Data Length - Defines the length of your text line (maximum of 128
characters).

M Input Mask - The mask consists of a string of mask characters and
separators. You can define your object input guide by choosing the mask or the
Validation Rules, when both the mask prevails.

Characte Meaning

ASCII alphabetic character required. A-Z, a-z.

ASCII alphabetic character permitted but not required.
ASCII alphanumeric character required. A-Z, a-z, 0-9.
ASCII alphanumeric character permitted but not required.
Any character required.

Any character permitted but not required.

ASCII digit required. 0-9.

ASCII digit permitted but not required.

ASCII digit required. 1-9.

ASCII digit permitted but not required (1-9).

0O 0o0wx X520 > =
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Characte Meaning

ASCII digit or plus/minus sign permitted but not required.
Hexadecimal character required. A-F, a-f, 0-9.

Hexadecimal character permitted but not required.

Binary character required. 0-1.

Binary character permitted but not required.

All following alphabetic characters are uppercased.

All following alphabetic characters are lowercased.

Switch off case conversion.

Use \ to escape the special characters listed above to use them as
separators.

— = AN VOO ITH=

Q Examples:

Mask Notes

000.000.000.000;_ IP address; blanks are _.

HH:HH:HH: HH:HH:HH; MAC address

0000-00-00 ISO Date; blanks are space
>AAAAA-AAAAA-AAAAA- License number; blanks are - and all (alphabetic)
AAAA-AAAAA;# characters are converted to uppercase.

M Validation Rules - Validation Rules are built up from expressions,
quantifiers, and assertions. The simplest expression is a character, e.g. x or 5.
An expression can also be a set of characters enclosed in square brackets.
[ABCD] will match an A or a B or a C or a D. We can write this same
expression as [A-D], and an expression to match any capital letter in the English
alphabet is written as [A-Z].

A quantifier specifies the number of occurrences of an expression that must be
matched. X{1,1} means match one and only one x. X{1,5} means match a
sequence of x characters that contains at least one x but no more than five.

Note that in general Validation Rules cannot be used to check for balanced
brackets or tags. For example, a Validation Rule can be written to match an
opening HTML <b> and its closing </b>, if the <b> tags are not nested, but if
the <b> tags are nested, that same Validation Rule will match an opening <b>
tag with the wrong closing </b>. For the fragment <b>bold <b>bolder</b></b>,
the first <b> would be matched with the first </b>, which is not correct.
However, it is possible to write a Validation Rule that will match nested brackets
or tags correctly, but only if the number of nesting levels is fixed and known. If
the number of nesting levels is not fixed and known, it is impossible to write a
Validation Rule that will not fail.

Suppose we want a Validation Rule to match integers in the range 0 to 99. At
least one digit is required, so we start with the expression [0-9]{1,1}, which
matches a single digit exactly once. This Validation Rule matches integers in the
range 0 to 9. To match integers up to 99, increase the maximum number of

© 2018 Bodno



Chapter 4. Design m

occurrences to 2, so the Validation Rule becomes [0-9]{1,2}. This Validation
Rule satisfies the original requirement to match integers from 0 to 99, but it will
also match integers that occur in the middle of strings. If we want the matched
integer to be the whole string, we must use the anchor assertions, * (caret) and
$ (dollar). When * is the first character in a Validation Rule, it means the
Validation Rule must match from the beginning of the string. When $ is the last
character of the Validation Rule, it means the Validation Rule must match to the
end of the string. The Validation Rule becomes #*0-9]{1,2}$. Note that
assertions, e.g. * and $, do not match characters but locations in the string.

If you have seen Validation Rules described elsewhere, they may have looked
different from the ones shown here. This is because some sets of characters
and some quantifiers are so common that they have been given special symbols
to represent them. [0-9] can be replaced with the symbol \d. The quantifier to
match exactly one occurrence, {1,1}, can be replaced with the expression itself,
i.,e. x{1,1} is the same as x. So our 0 to 99 matcher could be written as
Nd{1,2}$. It can also be written N\d\d{0,1}$, i.e. From the start of the string,
match a digit, followed immediately by O or 1 digits. In practice, it would be
written as Md\d?$. The ? is shorthand for the quantifier {0,1}, i.e. 0 or 1
occurrences. ? makes an expression optional. The Validation Rule M\d\d?$
means From the beginning of the string, match one digit, followed immediately
by 0 or 1 more digit, followed immediately by end of string.

To write a Validation Rule that matches one of the words 'mail' or 'letter' or
‘correspondence’ but does not match words that contain these words, e.g.,
'‘email', 'mailman’, 'mailer', and 'letterbox, start with a Validation Rule that
matches 'mail'. Expressed fully, the Validation Rule is m{1,1}a{1,1}i{1,1}{1,1},
but because a character expression is automatically quantified by {1,1}, we can
simplify the Validation Rule to mail, i.e., an 'm' followed by an 'a' followed by an
i followed by an 'I. Now we can use the vertical bar |, which means or, to
include the other two words, so our Validation Rule for matching any of the three
words becomes mail|letter|correspondence. Match 'mail' or 'letter' or
‘correspondence’. While this Validation Rule will match one of the three words
we want to match, it will also match words we don't want to match, e.g., 'email'.
To prevent the Validation Rule from matching unwanted words, we must tell it to
begin and end the match at word boundaries. First we enclose our Validation
Rule in parentheses, (mail|letter|correspondence). Parentheses group
expressions together, and they identify a part of the Validation Rule that we wish
to capture. Enclosing the expression in parentheses allows us to use it as a
component in more complex Validation Rules. It also allows us to examine which
of the three words was actually matched. To force the match to begin and end
on word boundaries, we enclose the Validation Rule in \b word boundary
assertions: \b(mail|letter|correspondence)\b. Now the Validation Rule means:
Match a word boundary, followed by the Validation Rule in parentheses, followed
by a word boundary. The \b assertion matches a position in the Validation Rule,
not a character. A word boundary is any non-word character, e.g., a space,
newline, or the beginning or ending of a string.
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Characters and Abbreviations for Sets of Characters

Element Meaning

C A character represents itself unless it has a special regexp
meaning. e.g. ¢ matches the character c.

\c A character that follows a backslash matches the character
itself, except as specified below. e.g., To match a literal caret at
the beginning of a string, write \A.

\a Matches the ASCII bell (BEL, 0x07).

\f Matches the ASCII form feed (FF, 0x0C).

\n Matches the ASCII line feed (LF, Ox0A, Unix newline).

\r Matches the ASCII carriage return (CR, 0x0D).

\t Matches the ASCII horizontal tab (HT, 0x09).

\v Matches the ASCII vertical tab (VT, 0xOB).

\xhhhh Matches the Unicode character corresponding to the
hexadecimal number hhhh (between 0x0000 and OxFFFF).

\Oooo (i.e., matches the ASCII/Latin1 character for the octal number ooo

\zero 000) (between 0 and 0377).

. (dot) Matches any character (including newline).

\d Matches a digit (QChar::isDigit()).

\D Matches a non-digit.

\s Matches a whitespace character (QChar::isSpace()).

\S Matches a non-whitespace character.

\w Matches a word character (QChar::isLetterOrNumber(),
QChar::isMark(), or ' ").

\W Matches a non-word character.

\n The n-th backreference, e.g. \1, \2, etc.

M Text Box - The multiline text box is used only if more than one line of input is
required and allows you to input text information. To input a new line the user
must press CTRL+Enter. By pressing only the Enter key will close the text box.

TextBox Properties

Columns 80

Rows |6

O Cancel

M Columns - Define the number of columns of you text box (max: 128)
M Rows - Define the number of rows of you text box (max: 128)
M Value - Defines the object as a numeric value.

M Minimum Value - Defines the minimum value reachable, normally used to
countdown.
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M Maximum Value - Defines the maximum value.

M Step Value - Define step value when updated, use negative value for
countdown.

M Decimals - Defines the number of decimal places.

M Alignment - Set horizontal alignment

M Prefix - Defines character set that precedes the number.
M Suffix - Defines character set shown after the number.

M Special Value - Is the value the object will assume after reaching the
maximum or minimum values.

™ Integer Value - Allows you to write any integer value in one line box.

Integer Value Properties

Minimum Value 1]
Maxirmum Value 559995
Step Value 1

Alignment | Right
Prefix
Sufix
Special Value

Ok Cancel

M Maximum Value - Defines the maximum value.

M Step Value - Define step value when updated, use negative value for
countdown.

M Alignment - Set horizontal alignment
M Prefix - Defines character set that precedes the number.
M Suffix - Defines character set shown after the number.

M Special Value - Is the value the object will assume after reaching the
maximum or minimum values.

M Date - Allows you to write any date value in single line box.
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Date Properties

Minimum Date |1800f01/01
Maxamum Date [2100/12/31

Alignment | Left
Calendar popup | Yes

Date farmat | yyyyMmdd

oK Cancel

[ Minimum Date - Set the minimum value to date to avoids backdating.

M Maximum Date - Set the maximum value to date to avoids introducing later
dates.

M Alignment - Allows you to align text date inside object.

M Calendar Pop-up - Every time you change settings on date field it pops up
a calendar to easy date manipulation.

] Fevereiro, | 2011 )
dom %eq ter qua 4qQui sex sab
30 ann[1]z2 3 2 5
G T g 9 10 11 1
12 14 15 16 17 18
20 21 22 23 24 25
27 28 1 2 3 4
] 7 8 G 10 11

O M

LY
o

wn

=]
L8]

M Date Format - Helps you set a date value format, you have some
predefined.

M Time - Allows you to write any time value in one line box.

Time Properties

Minimum Time |[B0:00:00

Maximum Time |23:59:59
Alignment | Left

Time format |khh:mm:ss

o 4 Cancel

[ Minimum Time - Set the minimum value to time to avoids backtiming

M Maximum Time - Set the maximum value to date to avoids introducing later
time.
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M Alignment - Allows you to align time text inside object.

M Time Format - Helps you set a time value format, you have some
predefined.

M Date and Time - Allows you to write any date and time value in one line box.

Date and Time Properties

Minimum Date |1900/01/01
Maximum Date |2100/12/31
Minimum Time |[00:00:00

Maximum Time |23:59:59

Alignment | Left
Calendar popup | No

Date & Time format | ywanyMMpdd (hb:mmess)

Ok Cancel

M Minimum Date - Set the minimum value to date to avoids backdating.

M Maximum Date - Set the maximum value to date to avoids introducing later
dates.

[ Minimum Time - Set the minimum value to time to avoids backtiming

M Maximum Time - Set the maximum value to date to avoids introducing later
time.

M Alignment - Allows you to align text date inside object.

M Calendar Pop-up - Every time you change settings on date field it pops up
a calendar to easy date manipulation.

o Feversiro | 2011 o
domn seg ter qua qui sex sab
3 ![1]z2 3 4 5
B T 8 9 10 11
12 14 15 16 17 18
20 21 22 23 24 25
27 28 1 ) 3 4
6 7T 8 5 10 11

J b
o WO M

!

J=t
L8]

[ Date and Time Format - Helps you set a date and time value format, you
have some predefined.
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M List - Allows you to create a list, composed by two columns, the first is an

index column and the second is the data column.

1 Lisk L4
Text Line

Text Box

Value

Integer Value

Date

Time

| Date and Time

?ﬂt
Database list

Text

Data

M Database List - Allows you to create a combobox to select the update data

to your object. This only works if connected to a SQL database.

List From database Properties
SQL Select

User column [0
Data Column |1

Limit Rows |40 L]

CameL

©® The SQL Select statement is part of the SQL code and below we describe
some examples in how to use that code, specially how to use the select

statement.
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g
SELECT column_name(s)
FROM table_name

© Lets consider the example below, from our internal database, where we
select the position, extension and salary fields, from the employee database.
This is the first step, the second is to set a condition, only consider the records
with the field salary with a value lower than 35000.
Now the selection is made and the condition is set.

List From database Properties

SQL Select
SELECT position, extension, salary
FROM employee
WHERH| salary<35000

User column |0

Data Column |1

Limit Rows 40

oK Cancel

M User Column - Here you define what column will be listed on the combo
box, as a reference to the Data Column.

[M Data Column - Define to wish column belong the data that will be shown on
the database list object.

M Limit Rows - Setup the maximum rows to be listed on the combo box, to a
maximum of 99.

© After we define the User Column as 0 and the Data Column as 1, we define
the column to be listed as the first (the count starts from zero) and the Data
Column as the second and the result will be as shown below.
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| Database list |l [
Text Line
Text Box
Value
Integer Value
Date 7 \{e :
Time List From database Properties
E::E and Time S0L Select
Database list SELECT position, extension, salary
FROM employee
WHERE| salary<35000
User column n
Data Column |1
Limit Fows |40 =
|| cancel |
Please enter text
[ Sales Fepresentative
Sales entative
Sales Representative
Mail Clerk
‘ Feceptionist

On your combo box is only listed the position field records (User Column 0) that
matches the condition (salary<35000). And when the position Mail Clerk is

selected the object assume the extension field record of the selected position
6261.

M Font Auto Adjust - Automatically adjust the font size, but only if font point
size is auto.

M Concatenation - Allows you to add a prefix or a suffix to your date and it
can be printable, to do that just check on the check-box.
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4.410.1.4 4.4.10.1.4 - Database

@ There are two ways to add an object linked to a database to the card
document. Open a database and drag and drop the fields like explained further
on this manual or create the object and then connect it to a database. We will
address the last option now.

After creating an object go to the Source Tab and select the Database option.

© After you have chosen this option your tab changes.

| Keyboard Input |
Print Counter

Print Date ‘
Keyboard Input

|Database
|item Link

When Item Double -Clickecm-

Save with document

No
Data Type

Text Box
Font auto adjust

Newer

- .
| Concatenation |

r 3 -
Database

[connect to Database ... |

Font auto adjust
Mevar

[Cencatenation

B o |  ouine [ ostion | aignment | cippn | posion | e

@ And the next step is to@ click on the button 'Connect to a Database'. The
Database Connection Wizard will start allowing you to connect to any database
you want.

After the database is opened, by default the object will be connected to the first
table and first column of your database, like shown on picture below. All you
have to do now is define the table and column that you want your object to be
linked to.

M Font Auto Adjust - When you have defined a size for your object it allows
you to choose if you want Bodno to automatically adjust the font size.
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E Database v II
= [ Connect to Database ... | AF
il o nt auto adjust /
o
| Never i | Mever v
] [ R e |
= Concatenation | Always
= |Expand to fit
2 | Shrink to fit
u
=4
3
(=3
0

[M Concatenation - Allows you to add a prefix or a suffix to your data and print
it. While in datatabase mode you can concatenate up to four columns on the
same object and define a prefix separator if needed.

Data Prefix
O ignore on print
Data Suffix

[ igriore on print
nncal:enate database columns
Column Prefix

Colymn

Employee 1D v J]
Column Prenx

Column

([ ot used) -])

Column Prefix

Colump
(_ (Not Used) j)

oK _Cancel
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o Bl Edt Wiew Dol Database wndow Help

Iﬂﬁ.l E:EI E.E E&E}ﬂsﬂﬂéﬁé -

Birth Date
(19720208 iD0:00:00) 2]

Hire Daté
|1991/03/29 (00:00:00)
Home Phane

{206)555-9857

Extornssan

y 1%

EFBEEBREROND _ﬂ

Zoom Out

As you can see the first element on our object is 'Employee ID' the one
connected by default and the two others we choose to merge in our object, the
first and last names.
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4.410.1.5 4.4.10.1.5 - Item Link

@ This option allows you to connect an object to another, assuming the same
values with automatic update.

nt

|

E Item Link ‘/‘\\ Itern Jnk

)

PFnnt Counter

Print Date Itermn

Keyboard Input ]
Database ; ;
item Link Font auto adjust EMPLYEE ID
. 1D BARCODE
Mewver ¥ 2D BARCODE

_- Concatenation

Scrpt

|

When you chose this option your tab changes, allowing you to chose an object
to link, showing on the list all objects that are on the card space and which is
possible to connect, in this particular case we have a card with three other

objects..

©® When connected, the object will assume the linked object value and every
time it is updated so is the object.
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4.410.2 -Image & Signature

© When you select an image object a new tab is added to properties tabs, the
Image Tab, where you will be able to define your image settings. But the source
tab also changes, allowing you to define the source settings of your image file.

From Disk ,—.—-’ From Disk

IEramiNsk T
From Camera or Scanner

Tide

Flease editimage From Signature Pad
From Photo Editor
Source From Database
. : Item Link
Updated

when item Double-Clicked
save with document

Yes
Format

_Image Free format

Face Detection

Mo
Open image editor

Only when error

4.410.2.1 4.4.10.2.1 - From Disk

© This option sets the image source as the disk. When the object is updated
the browser opens allowing you to pick an image from disk.

To open an object from disk the procedure is simple, just click on the ‘Browse
Image' button, add a picture object to your card and a window will open allowing
you to browse for your file.

Like shown on the picture below:
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™ Title - Here you can give a nameftitle to your image, it will be easier for you
to identify your object later in further operations.

M Source - Opens a dropdown list with all cameras or scanners that are

installed on your pc or mac.

M Updated - Your object is updated in five different situations:

| When Item Double-Clicked | -

|

On Edit View

Saource

[ From Disk

Before Print

Title

[when item Double-Clicked

On Custom View
When Load Document

Before Prant Card
After Print Card

FPlease browse image

Source

[lma-qe Free format | + |

............................................. (Image 1x1
Image 3x2
Updated [Image 2x3
When Item Double-Clicked |Image 4x3

[Image 630x480

Sawve with decument |Image 480x640

s

Format

Face Detection

[ Image Free format - l |

[ Image S00x600
|Image &00x200
|Image 1024x768
Image 768x1024
|Image 1920x1020

Image 1080x1920

\ rné E Em’lat
 No S
Open image editor f Only when error  +

Yes
Mo

[ Only when error

r

[ When Item Double-Clicked - When you double-click on top of the object it
will open the interface related to the source you have chosen.

[ When Load Document - Every time you open the card document.

M Before Print - Before the printing procedure it will open the interface related

to the source you have chosen.
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M Before Print Card - Before each time a card is printed it will open the
interface related to the source you have chosen.

M After Print Card - After printing each card it will open the interface related
to the source you have chosen.

[ Save with Document - Save the image with the document so you don't lose
any data, but on the other hand, if you don't want to keep the image for a
smaller card document just chose 'No'".

M Format - The image can have a pre-established format, like shown on the
image above, adapting the image to it or a free format, allowing you to keep the
image source format.

[M Face Detection - When you chose yes, after the image as been acquired
the image editor opens, allowing you to chose the face detection option.

M Open Image Editor - You can open the editor every time the image is
updated (yes), never open the editor (no), or open the editor only when an error
is detected (Only when error).

4.410.2.2 4.4.10.2.2 - From Camera or Scanner

O After you add an image to your card, the first thing that opens is the image
editor, but you can change your image source any time you want and a camera
or scanner is one of your options.

I | e e Doubi-clcked

[5“'-”":9 GnEustornig e

. - 4 | On Edit View
From Camera or Scanner When Load Document
: Before Print
Title Before Print Card

| After Print Card

Please browse image
Source

Image Free format
TeErother DCP-J315W LAN | Image 1x1
Image 3x2
Updated Image 2x3
when Item Double-Clicked Image 4x3
; Image &40x4 80
Save with document Image 480x640
Image 200x600
s ; y Image 600x200
Image 1024 x768
cormt Image 768x1024
Image Free format Image 1920x1080
kel - - Image 1080x1920
Face Detection A Image Free format
No i
Open image editor /-‘-/ Only when eror | ~
Yes
Only when error NO
) ) [Onlywhen error |
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After choosing this option, your source pad changes allowing setup of the
camera or scanner options.

™ Title - Here you can give a nameftitle to your image, it will be easier for you
to identify your object later in further operations.

M Source - Opens a drop down list with all cameras or scanners that are
installed on your pc or mac.

M Updated - Your object is updated in five different situations:

[ When Item Double-Clicked - When you double-click on the object it will
open the interface related to the source you have chosen.

M When Load Document - Every time you open the card document.

M Before Print - Before the printing procedure it will open the interface related
to the source you have chosen.

M Before Print Card - Before each time a card is printed it will open the
interface related to the source you have chosen.

M After Print Card - After printing each card it will open the interface related
to the source you have chosen.

[M Save with Document - Save the image with the document so you don't lose
any data, but on the other hand, if you don't want to keep the image for a
smaller card document just chose 'No'.

™ Format - The image can have a pre-established format, like shown on the
image above, adapting the image to it or a free format, allowing you to keep the
image source format.

M Face Detection - When you chose yes, after the image as been acquired
the image editor opens, allowing you to chose the face detection option.

M Open Image Editor - You can open the editor every time the image is
updated (yes), never open the editor (no) or open the editor only when an error
is detected (Only when error).
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4.410.2.3 4.4.10.2.3 - From Signature Pad

© Signature pad is a signature acquisition device, Bodno works essentially
with two kinds, the Topaz or any device that work with WinTab drivers.

The acquisition procedure is simple: click on the 'Signature’ button and add the
signature object to the card a list will pop-up to allow you to chose the device in
case of the Topaz, like shown below.

After choosing the device the interface window will show and wait for you to
add the signature to the device like in the pictures below:

] Wack Fen Previare Clnar o

TOPAZ WINTAB

The Topaz device also allows you to have templates for the signature frame. The
Wintab driver has a track pressure setting that according with the pressure
made by the pen, makes the line thinner or thicker.

Like any other image object, Bodno allows you to use an existing object, all you
have to do is to click on the object and change the source to 'From Signature
Pad' and starts the procedure of signature acquisition.

M Source - Opens a dropdown list with all signature devices that are installed
on your computer.
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M Updated - Your object is updated in five different situations:

Pliaaie seloct yoor Sniturs Diace fram the It below

Topaz Saploe LCD 13 Backde
iory. T

Source

From Signature Pad
When Itern Double-Clicked
|when Item Double-Clicked

Title

| On Custom View Flease sign here
On Edit View Source
when Load Document 4
Before Prnt - -~ Topaz Signature Pad
Before Print Card
After Print Card Updated
Image Free e -\\u____,..-‘ Wwhen Itern Double-Clicked
Image 1xl Sawve with document
Image 3x2
Image 2x3 g
Image 4x3
Image 640x4 80 - E
Image 480640 OrTngk

Image B00x600
Image G00x800
Image 1024x763

Image 768x1024 g
Image 1080x1520

[Image Free format

Image Free farmat

[ When Item Double-Clicked - When you double-click on the object it will
open the interface related to the source you have chosen.

[ When Load Document - Every time you open the card document.

M Before Print - Before the printing procedure it will open the interface related
to the source you have chosen.

M Before Print Card - Before each time a card is printed it will open the
interface related to the source you have chosen.

M After Print Card - After printing each card it will open the interface related
to the source you have chosen.

M Save with Document - Save the signature image with document so you
don't lose any data, but on the other hand, if you don't want to keep the image
for a smaller card document just chose 'No'.

™ Format - The image can have a pre-established format, like shown on the
image above, adapting the image to it or a free format, allowing you to keep the
image source format.
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4.410.2.4 4.410.2.4 - FromImage Editor

€@ The Image Editor brings you new tools for image editing, there are many
ways to open the image editor, but to acquire only one, open an image object
and then change the source to 'From Image Editor".

Ldadalm AEK @

On the tool bar you can set these settings on your image:

M Rotate clockwise - Is the circular motion is one that proceeds in the same
direction as a clock's hands: from the top to the right, then down and then to the
left, and back up to the top.

M Rotate counter-clockwise - Is the circular motion is one that proceeds in
the opposite direction as a clock's hands: from the top to the left, then down and
then to the right, and back up to the top.

4 Flip Horizontal - This option reverses the active object horizontally, that is,
from left to right. It leaves the dimensions of the object and the pixel information
unchanged. It looks as if the image has been reflected along the central vertical
axis of the object.

4 Flip Vertical - This option reverses the active object vertically, that is, from
top to bottom. It leaves the dimensions of the object and the pixel information
unchanged. It looks as if the image has been reflected along the central
horizontal axis of the object.

M Brightness and Contrast - The Brightness/Contrast adjustment lets you
make simple adjustments to the tonal range of an image. Moving the brightness
slider to the right increases tonal values and expands image highlights, to the left
decreases values and expands shadows. The contrast slider expands or shrinks
the overall range of tonal values in the image. To change values you can drag
the slider to the left or to the right or setup manually typing the values on the
boxes. The values can go from -128 to 128.

© 2018 Bodno



m Bodno Manual

[M Color Balance - Is the global adjustment of the intensities of the colors
(typically red, green, and blue primary colors or RGB system). Changing the
overall mixture of colors in an image and is used for color correction and when
you drag any of the sliders, you can see those corrections taking place,
adjustments are made to the color values RGB (on screen) or CMY (on
printers). The values can go from -128 to 128.

M Color to Grey - Apply gray scale on the image in which the value of each
pixel is a single sample, that is, it carries only intensity information. Images of
this sort, are composed exclusively of shades of gray, varying from black at the
weakest intensity to white at the strongest.

M Color to Monochrome - Not a combination of black and white in a
continuum producing a range of shades of gray, but really starkly contrasted
black and white.

M Zoom In - This tool allows you to obtain a larger image, or a closer view.
M Zoom Out - This tool allows you to obtain a smaller image, or a farther view.
M Zoom Auto - Reset image fo its initial size.

™ Export Image - You can save the image as... in many different formats like
png, jpg, bmp, tiff and others.

M Select Image Acquisition Source - Allows you to select the image
acquisition source from any device that is connected or installed on your pc. It
may appear some devices that are not connected but are installed.

M Image Acquisition - This tools opens the interface related with the image
acquisition source you had chosen.

M Open Image File - Opens an image file from your system, including disk,
USB key, memory card or any other source.

M Select Image File Path - Allows you to chose your default image file path
from all that you had already used before on your document.

M Face Detection
M Face Detection Setup

M Undo - It erases the last change done to the document reverting it to an
older state.
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[ Clear Image - Erases the image from Image Editor.

[M Cut / Crop - On Bodno crop tool you don't use the traditional handlers, the
visual area is automatically resized to the image object boundaries, to cut/crop
the image all you have to do is to drag or zoom in on the image and every thing
that is on the blur area (gray and black squares) when you click the cut/crop
button, goes away. And the image is automatically adjusted to the object area.

M Save Changes - Click on this button to accept the changes.

M Cancel - Click on this button to cancel the changes.
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4.410.2.5 4.4.10.2.5 - From Database

©® Bodno allows you to connect an image object to a database image, this way
you can setup the object as you want and then connect to the database image
adapting it to your object.

The procedure is simple, first add a image object to your card change the
source to 'From Database’.

© | not connected to a database yet @ click on the 'Connect to Database'
button.

. The connection wizard will start

@ After the connection is made, if there is no image field, the link is not made
and the list stays like the image below, empty.

If there is only one image field, the Bodno recognizes it and the link is
automatic.

© If more then one then a list will show you the options for you to chose,
like shown below.

- ; - ) ] O S )
[Phatg cardip Image
|Ruwi Faria F20Mr54 35 Ch\Users\PublichPictures\Sample Pictures\Penguins.jpg
|Jodo Lucas 312448035  CAUsers\Public\Pictures\Sample Pictures\Koala.jpg
|Daniel Gomes B2EDTFIS  C:\Users\Public\Pictures\Sample Pictures\lellyfish.jpg
|Nune Martins F2D09435
|carlos Pinheira 32048035
I
DATABASE
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roge ]

lSOurca ‘

| From Database -

Table

:_Em_duyee v
Column
[ Photo -| | @rhoto e

Photo
image

Save with document
[ No v

Face Detection

Open image editor

—
Only when error >

O If you add a field image, please don't forget to refresh the database.

4.410.2.6 4.4.10.2.6 - Item Link

@ This option allows you to connect (link) one object to another object,
assuming the same data values with automatic updates.

When you choose this option your tab changes allowing you to choose an
object to link, showing on the list all objects that are on the card document that

you can connect to,

2 For the next sample we will use an image object.

@ When connected, the object will assume the linked object value and every
time it is updated, the first object will also reflect the data from the linked object.
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This option allows you to have two image objects, one at the front of the card
and another at the back of the card, sharing the same data.

4.4.11 - Alignment

©® The alignment tab allows you to define the object alignment inside the
boundaries.

[Alignm ent

Select your item alignment

As you can see you can define vertically from top, middle or bottom and
horizontally from left, middle or right.

When the point size is in auto, on the font tab, it means that the font size justify
the text to the boundaries what makes the horizontal adjustment very small

© The default position is left and middle.
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4412 - Script

© There are two different locations where you can write in Bodno's design
area. One for each object and one for the document. In this chapter we focus
on the object script.

This is an advanced user area, where you can program actions and procedures
in javascript language in order to define settings or update your object.

Scnpt

when Item Double-Clicked )
[When item Double-Clicked
On Custom View
On Edit View
when Load Document
Before Print
Before Print Card
After Pant Card
Record changed

®
script [output ¥ g

1) This drop-menu allows you to define when the actions or procedures must
take place.

@ Andin the space below you can write your lines of code.

9 To see the log of your program output, change tab below.
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4.4.13 - Multi Align
@ The multi align tab is only displayed when three or more objects are selected
and is divided in two classes, the alignment between objects and the
distribution.

|M ulti-Align ~|

( Alignmertt Between Objects )

M Alignment Between Objects - Aligns vertically and horizontally the objects
to top, middle or bottom and to left, middle or right using as boundaries the card
limits.

M Distribution - Allows you to distribute the objects on the card area equitably,
but instead of using the card limits as a reference uses the object boundaries
referring to the last object selected that is marked with blue selection handles.

All other objects will be allocated according to the selection and having as a
reference the last one selected, notice that the reference object is also the
anchor and will not move, all the others will be placed according with the
distribution settings.

In short, the space occupied by the three or more objects will always be the
same, the space between them is the one that will be arranged.
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Chapter 5. Database

O A database is an organized collection of data. A database is typically
organized to model relevant aspects of reality in a way that supports processes
requiring this information

This chapter explains you how to connect to a database through Bodno and
how to use it to your advantage

5.1 - Connection
@ In Bodno there are two ways to connect to a Database.

One of them is by clicking on the Connect Database icon in the Dockbar.

L

The other is by selecting Connect in the Database Menu.

* Fle Edit View Tool gatahase Window Help

Connect
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5.1.1 - Configuration

© Depending on your Bodno Edition there are several Database Drivers at
your disposal:

BRONZE has an internal database with photo connection.

SILVER has the Direct CSV & TXT File Driver, that can only read the fields in
these databases. Edition of their records isn't possible through Bodno.

And the Direct Excel File Driver through which Bodno can edit the fields and
records of the Database.

With these drivers it is also possible to add Links to images and their Folders.

GOLD can connect to SQLite version 3 and the Direct MS Access File
Driver. From here on it is possible to Alter Tables and in the records add
images as Binary file.

The Bodno Internal Database (msAccess) becomes available in this Edition.

PLATINUM adds the ODBC Drivers and with them it is possible to connect to
any Database with ODBC Support, like: SQL Server; Oracle; MySQL; as others.

Database Driver
Please select the database driver that identifies your database connection.

) .

Internal Database (msAccess)

Direct C5V & TXT Fle Driver

Direct Excel Fle Driver

SQLite version 3

Direct Access Fle Driver

Open Database Connectivity (ODBC)
Open Database Connectivity (ODBC ansi)
MySQL Driver

< Back l Next = [ cancel |

After selecting the Driver you will be prompted to Select or Browse to the
Database.
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Database
Please select the database that you wish to connect to.

QODBC:Open Database Connectivity (ODBC)

Database [| 7‘

Connection Options | |

|ODBC Administrator |

Or

IEmrwse Fur*.csu]

Prompt for credentials

[ < Back |l Next = |[ cancel |

©® The instructions on how to configure each Driver connection, will be
addressed further on this manual.
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5.1.1.1 - Direct CSV & TXT Driver

© I|n the Direct CSV & TXT Driver there are several configuration options,
usually Bodno Guess function does the required configuration when the CSV
or TXT file are opened.

e @
e fokds ar S
Sample.txt | Mumber l EE?G
Ale Encading Adta o =] |11 NAME 150 8839-1
J Date . )
r— 1 Photo Feld delimited ‘
Type Feld delimited * rField DG |
. | | Fxed Pecord Size
2l ! o | |Banking Structured File
[ Has columns he—ader] 1 =] . | o _
| G
Feld .
#
<TAE>
<AUTO>
Typee §
| String .
|String |
Integer Mumber
Guess QI Cancel Fractional Number
| Date
Time

| Date and time

@ File Encoding - The File encoding is by default as 'Auto’, if the encoding
used by the database is on the dropdown list chose it.

& Type - Is for the Size of the Fields in the Database.

@ Delimiter - It is possible to chose the Delimiter used in the Database or Input
it.

@ Field Type - Select the Field Type accordingly.

© Explanation on the next connection steps will be addressed further on this
manual.
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5.1.1.2 - Direct Excel Driver

@ In the Direct Excel Driver it is possible to confirm the structure of the
database and if needed add more Fields to it. The Bodno Guess recognizes
the structure and configures the connection, if the configuration isn't correct,

change it accordingly.

File Felds
armiple.adsx 1D

Mame
Worksheet Sample @ | Diate

Phat
Header Al (ID) . we
Data A2 @

Guess O

Integer Number

Fractional Mumber

Date
Time
Date and time

1T’ Worksheet - Chose the Worksheet to which the card is to be connected.

@ Header - Select the Header of the Database.
[ Data - Select from where the Rows start.

4 Type - Select the Field Type accordingly.

© Explanation on the next connection steps will be addressed further on this

manual.
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5.1.1.3 - Direct MS Access Driver

® Since the data stored in the MS Access and the SQLite Databases has a
fixed format, no special configuration is needed. Just browse to the Database
and open it, and select which table you want to import.

The Bodno Internal Database is a MS Access Database provided with the
Bodno installer and serves as a Sample and for test purposes.

Database
Please select the database that you wish to connect to.

OMDE:Direct Access Fle Driver

Database |ASEfinternalDatabase.mdb f]

Browse Fur*.mdb]

[ Prompt for credentials

[ -:Back” Next = H Cancel ]

© Explanation on the next connection steps will be addressed further on this
manual.
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5.1.1.4 - Internal Database

@ Each Bodno document contains an internal database as a smaller yet more
convenient way to keep records. This means you can have your own database
records saved within the Bodno document itself, without need of external
database files.

To connect to the internal database you can use the Connect to Database
button.

On the following window select document Internal Database.

Database Driver
Please select the database driver that identifies your database connection.

document Internal Database

cardPresso Internal Database (msAccess)
Direct C5V & TXT File Driver

Direct Excel File Driver

SQLite version 3

Direct Access File Driver

Open Database Connectivity (ODBC)
¢ Open Database Connectivity (ODBC ansi)
i MySQL Driver

< Back | Next> || Cancel

You can then use Database Operations to create your own tables and columns
and save them on your Bodno document.
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© The Open Database Connectivity (ODBC) provides the means to connect
to several Databases, such as, SQL Server, Oracle, IBM, Fox Pro, dBase and

others.

In case of Databases containing special characters, the usage of the Open

Database Connectivity (ODBC) ansi is advised.

Database
Please select the database that you wish to connect to.

2

-

QODEBC:0pen Database Connectivity (ODEC)

Database |

Connection Options

|ODEC Administrator

User DSN |System DSN I File DSN I Drivers I Tracing I Connection Pooling | About | '

)

User Data Sources:

Name: Driver
——————4
Microsoft Excel Driver ("xs. “xdsx. ~xlsm, ~x
) Rem
MS Access Database  Microsoft Access Driver ("mdb, *.accdb) ‘P—w" I Cancel

| Add...

Configure

3

& An ODEC User data source stores information about how to connect to
D} the indicated data provider. A User data source is only visible to you,
— and can only be used on the curent machine.

Cancel Apphy Help

¥ o

Select a driver for which you want to set up a data source

Name

Driver da Microsoft para arquivos testo (“bd; *.csv)
Driver do Microsoft Access (“mdb)

L] »

Driver do Microsoft dBase {*.dbf)
Driver do Microsoft Excel(*xls)
Driver do Microsoft Paradox (".db )
Driver para o Microscft Visual FoxPro
Microsoft Access Driver (*mdb)

LR o o <

4

4| 1

By selecting the ODBC Administrator these options are available:

User DSN - Shows the existing connections and provides the possibility to Add

more connections and Remove or Configure existing connections.

System DSN - Shows the existing connections and provides the possibility to

Add more connections and Remove or Configure existing connections.
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File DSN - Provides the means to connect to a data provider.
Drivers - Shows the connection Drivers installed on the system.

Tracing - Provides the means to log the calls to the ODBC drivers for use by the
support personel or to aid in debugging your applications.

Connection Pooling - Provides the means to reuse open connection handles.

About - Shows the ODBC core components available.

© Please contact your SysAdmin for the configurations required to connect
with your Database.

© Explanation on the next connection steps will be addressed further on this
manual.
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5.1.1.6 - MySQL Driver

@ The MySQL Driver allows to connect to a MySQL Database.

Database
Please select the database that you wish to connect to.

QMYSQL:MySQL Driver

Database [tESt v]

Hostname |1l].l].2.2 |

Port |Default

Connection Options | ]

Usemame |mut ]

Password | ]
Keep credentials

Prompt for credentials

[ 2.2 H Cancel I ’ack H Next = H Cancel ]

@ Please contact your SysAdmin for the configurations required to connect
with your Database.

© Explanation on the next connection steps will be addressed further on this
manual.
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5.1.2 - Database Operations

@ The Database Operation is an important function for GOLD and higher
Editions. In the Database Operation it is possible to Select, Create, Alter or
Drop Database Tables, making it possible to personalize a Database with
Bodno.

Since the CSV, TXT and Excel Databases do not have multiple Tables only the
Select Table is possible in their case.

Database Operation
Please select the operation you wish to perform on your database.

3
4

OMDEB:C:/ProgramDataf e JDATAEBASE/internall

Operation | Select Table | «

Select Table
Employ Create Table
Alter Table

Drop Table
Select View
Select...m Table
Select ALL

TABLE,12 Columns

| < Back | Next = Cancel

This example is based on the Bodno Internal Database.
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5.1.3 -Table Columns

O In this part of the Database Connection Wizard it is possible to select which
columns of the selected Table you need. Columns order will be defined
according to your selection.

Table Columns
choose Table columns

‘ C:/ProgramDatal e JDATABASESinternalDatabase. mdb -
Columns
Employee ID [2]

Supervisor ID
Last Name
Arst Name
Position
Birth Date
Hire Date

[[] Home Phone
Extension E

7] Mt

[H select all columns

< Back | Next> [ Cancel

[ Select all columns [ Select all columns At least one column must be selected]

@ If no column is selected the Wizard won't continue.
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5.1.4 - Guide Columns

@ The Guide Columns will work as an Index of the Database.

Guide columns
choose Guide columns

CProgramData) coceeeememe. DATABASESnternalDatabase.mdb -
Guide columns

Employee ID [a]
Supervisor ID
Last Name
First Mame
Position
Birth Date
Hire Date
Home Phone
Extension F

[ -::Back” Mext = H Cancel ]
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5.1.5 - Database Filter

© In the Database Filter you can add conditions to filter what is shown from
the database. These conditions have to be written in SQL Script without the
"Select * where".

Flter
Flter

C:/ProgramData/ coece. J/DATABASE/internalDataba

Database Filter

-::Back” MNext = ][ Cancel ]

Flter
Flter

C:/ProgramData) e JDATABASEfinternalDataba

Database Filter

“Supervisor ID” = 5 OR " Supervisor ID” = 2

[ < Back ][ Next = ][ Cancel
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5.1.6 - Order Columns

@ With the Order Columns it is possible to change how the columns' contents

is shown in Bodno.

The organization rules used by Bodno for the selected columns are:
Empty fields first, then the Numeric fields from the smallest value (0) to the
biggest value (19), followed by the fields in Alphabetic order.

Order Columns

choose Order columns

C:/ProgramData/ ...cee.

Order columns

......... JDATABASE/internalDataba

Employee ID [1]
Supervisor ID
Last Name
Frst Name
Position

Birth Date

Hire Date
Home Phone
Extension

E

< Back H Finish H Cancel ]
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5.1.7 - Properties

O It is possible to review the configuration of the Database
connection through the Database Menu and selecting
Properties.

Window Help

% Import

& Disconnect
& Refresh
& Properties

& First record
& Previous record
& MNext record
8 Last record

® Insert record
2 Delete record

© The Database Properties are mainly used to check the configurations of the
connection. Do not change them unless necessary.
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Connection Properties

Property Value

4 Connection
Timeout —
Driver QMDB
Host
Paort -1
Database C:/ProgramData/ ...
Usemame
Keep credentials
Table Employee
ko5
Saved images format AUTO |~
Include Images in recurdset
Database thumbnails Yes |
Requery on insert Auto |~
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5.2 - Dockbar

5.3 - Database

@ As it is with Bodno Document Objects, the Database Fields can also be
added to the card Layout through Drag & Drop. These Objects will be connected
to the Database Field and update when the field in the database is changed or
when moving between records.

*msamwmamu window  Help

[+]
-
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5.4 - Find or Filter

@ The Database Find Tab eases the search for specific records in the
Database.

It is possible to search in the available variables if the data in a column of the
Database is or has a value, as input by the user to the Textbox.

W e Edt yew Bool Detabase yindow help
IEEEE OcEaE AAR DR RIEEE - & -

-

ﬁﬁﬁﬁ&&ﬁﬂﬁi

[<

9 The Database Filter works as an SQL Query and in it there are available the same options as in
the Database Find with the possibility to search with multiple rules and with a personalized Script.

The Database Filter Tab can also be used to generate the Script for the Database Filter in the
Connection Wizard.
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Layouts

Database

Database Filter

Database Find

Database
C:/ProgramData/ ... /DATABASEfinterna

Table Employee
Record 1 of 19

Conditions,

[ Supervisor D (v} [Z|

[ Is Equal (=) v J

Chapter 5. Database

Is Equal (=)

Is Equal (=)

Is Mot Equal [<>)

Is Bigger {>)

Is Bigger or Equal (>=)
Is Smaller (<)

Is Smaller or Equal {<=)
Is Mull (IS5 NULIS

I1s Mot Mull (IS NOT NULL)
Contains (LIKE)

Mot Contains (NOT LIKE)

[Dr -

l Supervisor ID - ] [3

[ Is Equal (=) v ]

3

| Add Condition ... v

sqL:
“Supervisor ID” = 5 OR " Supervisor ID” = 3

[.ﬁdd Column ...

Add Column ...

Employee ID
Supenvisor 1D
Last Name
First Name
Position
Birth Date
Hire Date
Home Phone
Extension
Photo
Notes
Reports To
Salary
SSN
Emergency Contact Frst Name
Emergency Contact Last Name
Emergency Contact Relationship
%rner‘gency Contact Phone
st

[ Add Condition ...

|

Reset Apply J

Add Condition ...
And

Or

When using the Contains filter, if you are searching with a partial word, you must use the % symbol
on the search term.

Eg: Searching for a word that starts with "Bo": Bo%

Searching for a word that ends with "dno": %dno

Searching for a word that contains the text "odn": %0dn%
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5.5 - Database View

Browsing and editing a database is made simple with the Database View.
Here you can see a list of all the database records and edit them with in a
convenient interface, made to simplify browsing and editing records.

To access the Database View, click the Database View button or open the
Bodno menu View > Database View.

O Note: The Database View will only show data when connected to a
database.

BESEN LEEE A EEEE BT

M Browse Records - Opens the Browse Records tab which lists all the
records in a reader friendly way .

M Edit Records - Opens the Edit Records tab provides you with a more
convenient interface to edit each database record.

5.5.1 - Browse Records

The Browse Records view is a tool that allows you to see all the records in
your database in a simple and reader friendly environment.

Here you can also individually select records for when you want to print several
specific records in the database (see more on Printing Selected Records in a
Database).

You can access the Browse Records window through the Database View
button, then Browse Records button, or through the Bodno menu View >
Database View, then Browse Records Button.

Double-click above a Record to edit it. When doing so, you will be redirected to
the Edit Records tab. When finishing your edition, Save changes and return to
Browse Records view.

© 2018 Bodno



Chapter 5. Database m

mEEEes o= W !

M Hide/Show Photo Columns - Toggles between hiding or showing database
columns which contain images. Ideal for larger databases with a large amount of
pictures, which can be very memory intensive.

When disabled this option allows for higher performance in computers with
slower resources.

™ Select All - Selects all the records in the database.
¥ Select None - Deselects all the records in the database.
M Toggle Selection - Individually toggles the selection on all database items

that are listed (Does not apply to items that are not visible through Database
Filter).

5.5.2 - Edit Records

The Edit Records view is another powerful tool in Bodno which allows you to
quickly edit database records, making database management fast and simple.

On the left side of the Edit Records window you can find the columns which

contain text.
On the right side, you can find all the the Image items contained in the
database.

L~

Simply browse the records with the top Database Toolbar until you find the
database record you want to edit, then edit the database record and click the
Save Record button.
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5.6 - Managing Records

Adding, deleting and editing records are core tasks when managing a database
and when working with large databases, it can become a time costly task.

With all the tools provided by Bodno, managing databases becomes simple and
intuitive.

5.6.1 - Adding Records
Adding records in Bodno is quick and simple:

1 - Make sure you are connected to a database (see more on chapter 5.1 -
Connection)

2 - Open the Database sidebar when working on the Card Design view (see
more on chapter 5.3 Database).

Alternatively open the Browse Records window on the Database View (see
more on chapter 5.5.2 Edit Records).

3 - Click the Insert Record button on either the Database Toolbar or through
the Bodno menu Database > Add Record.

o

4 - The Database ltems will now be empty and ready to be written.
Finally, fill the items with the required data and click the Save Record button to
save the changes.

-

Prior to saving you can cancel any changes with the Revert Record Changes
buton:

-
-y
5.6.2 - Editing Records

Editing existing records is also a quick and simple task:

1 - Make sure you are connected to a database (see more on chapter 5.1 -
Connection)
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2 - Open the Database sidebar when working on the Card Design view (see
more on chapter 5.3 Database).

Alternatively open the Edit Records window on the Database View (see more
on chapter 5.5.2 Edit Records).

4 - Use the database toolbar to find the record you wish to edit.

— — — ]

4 - Finally, fill the items with the required data and click the Save Record button

to save the changes.
]
&

Prior to saving you can cancel any changes with the Revert Record Changes

buton:
]
&)

Deleting existing records is also a quick and simple task:

5.6.3 - Deleting Records

1 - Make sure you are connected to a database (see more on chapter 5.1 -
Connection)

2 - Open the Database sidebar when working on the Card Design view (see
more on chapter 5.3 Database).

Alternatively open the Browse Records window on the Database View (see
more on chapter 5.5.2 Edit Records).

4 - Use the database toolbar to find the record you wish to delete.

— — — ]

5 - Click the Delete Record button and when prompted if you want to delete the

record, click the Yes button.
.y
(=)

Note: Deleting a record is a permanent action that cannot be reverted, canceled
or undone.
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Chapter 6. Printing

© Printing your cards is the core function of Bodno. Within this chapter we
describe the several printing configurations Bodno provides for printing and
how those settings work with your printer to achieve the best printing results.

To ensure that the finished card appears as intended you should understand
basic printing principles such as the resolution of your printer or the calibration
and resolution of your monitor. These specifications are provided by the printer
manufacturer and in the display settings of your Operating System.

Make sure you have the latest printer driver and firmware versions for the printer
you have installed.

6.1 - Printing with Bodno

@ The computer you wish to print a card from must be connected either to a
local, shared, or network printer and be configured to use that printer.

1. Make sure that you've installed the correct printer driver for your printer.

2. Q Click the Print Button, or choose File > Print.

3. If connected to a database (see more on Chapter 5. Database) you can use
the Database Selection options to select the records you want to print (see
more on Chapter 6.1.1 Printing With a Database):

4. Update record after print writes a user determined value in the selected
database field of each database record that is printed, after being printed.

5. Copies sets the number of copies to print for each print job / record.

6. Advanced Options opens the Printer Driver properties of your currently
selected printer. Set additional printer driver options in your operating
system. See your printer driver documentation for details.

7. Print Operations allows you to select the operations you wish to run on
each print job.

Click OK to start the print job with your currently selected options.
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Primter g Micr it XPS L nk J .
Manufacturer Microsoft
Dvver Microsoft XPS Dacument Witer
S |Deiver Options| gy
Database Print Oparations
Selaction: ¥ Pant Front
[ Range 1 Prnt Back

Fram | Start Pecord + | Number of records 1 e

O Selected Records in browse view
[ condtonal prnt |

Update
O update Pecord After Print

Copies

Number of copses |1 =

ok || cClese || cancel |
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6.1.1 - Printing With a Database

O Print jobs with large databases can be very lengthy and complicated. That's
why Bodno provides you with several options you can use to your advantage
to, make printing with large databases a much simpler job.

6.1.1.1 - Printing a Database Range

© Print Range allows you to choose a range of records within a database to
be printed automatically. This range can vary from one card to several cards.

1 - In the From field, select the starting point you want for your print job.

2 - In the Number of records, type the number subsequent records you want
to print.

When selecting a range, you have 3 options to select which is the record you
want to start to print from:

Start Record starts printing from the first database record.

Current Record starts printing from the database record that's currently open.
Last Record starts printing from the last database record.

All Records prints all the existing records in the database.

Custom Records allows you to define a specific range of records to be
printed. Use comma (,) to enumerate records and dash (-) to choose a range of
records (e.g. 1, 3, 5-9).

After selecting which record to start from, Number of records let's you choose
how many subsequent records you want to print besides the starting record

Database
Selection:

Range

From | Start Record | Number of records |1

| Start Record H
O selectel | rrent record [W

[ Conditi Last Record

Eg: If selected From: Start Record, Number of records: 700 Bodno would
print all database records ranging from 1 to 100.
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6.1.1.2 - Printing Selected Records in a Database

© Selected Records in browse view lets you select which records to print,
one by one, by selecting them previously in the Browse Records window in
Database View.

1 - @ Click the Database View button, or choose View > Database View

2 - Select the records you want to print on the Browse Records window, using
the checkboxes.

3 - @ Click the Print button, or choose File > Print.

4 - Select the Selected Records in browse view option and click OK to print.

= LEBeE SAN . HEEEEE - BE .

Database C:/ProgramData/cardPresso/DATABASE/internalDatabase.mdb, Table:Employee
2 ﬂiﬂ

Print

[
Printer | g Microsoft XPS Document Witer

Manufacturer Microseft
Driver Microsoft XPS Decument Witer
x

Database Print Operations

Selection: Print Front
Print Back

[] Range
Selected Records in browse view

[ conditional print

Update
[] Update Record After Print

Copies

Number of copies

[ OK H Close Il cancel |
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6.1.1.3 - Printing with Conditional Printing from a Database

@ Conditional Print lets you configure a print rule using a value from the
database records. When printing, Bodno will search through all records within
the database and will only print the records that comply to the rule you have
configured.

1 - Select the database Column which contains the data to be validated.
2 - Select the condition that fits the print rule you want.
3 - Click OK to print only the database records that follow your print rule.

Database
Selection:
[J Range
[ selected Records in browse view

Conditional print

Column Employee ID Is Mot Null

[Is Equal
Is Mot Equal
[Is smaller
Update |Is Smaller or Equal
Is Bigger
[0 Update Record After Print Is Bigger or Equal
Contains
Mot Contains
{15 Null
is Not Mull
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6.1.1.4 - Update after Print

© Update Record after Print allows you to change a record to save relevant
print information, after being printed.

By using your own text or one of the options available in Bodno it is easier to
mark in the database the records that have been printed, the amount of cards
printed for that specific record and/or the print date of the last card.

1 - Select the Column wich you wish to update.

2 - Type the data you want to store, or choose one of the available options
Bodno provides.

Update
Update Record After Print
Column ETplnyee ID 17| Apply your text here or
name of your database column (SPRINTSTATUS
| SPRINTCOUNTER
| SPRINTDATE
| SPRINTSTATUS&COUNTER
| SPRINTS TATUS &COUNTER&DATE
6.1.2 - Copies
@ Number of copies lets you set the number of times each card will be
printed.
Copies

Number of copies |1
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6.1.3 - Print Operations

@ In the Print Operations you can find the print and encode tasks that occur in
each print, depending on the Card Type in use.

As an example, a CR-80 Card Type layout would only show the Print Front and
Print Back operations.

Print Operations

Print Front

[T] Print Back

Magnetic Encoding

[ Contact Encoding

[[] Contactless Operations

O me operations selected in this area are the only ones sent for printing.
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6.2 - Print Settings

© Printer Settings allows you to configure the basic layout settings of your
card, configure Print Options which adapt to your printing needs, and gives
you access to your printer's Advanced Options.

Q To configure your Printer Settings, click File » Configure print or
CTRL+P.

1) Paper Size, selects the paper size supported by the chosen printer.

@ Orientation, selects the orientation of your document. Landscape or
Portrait.

9 Print Layout, selects the card model you wish to print to.

In print situations as shown above, in this case to paper, we also provide you
with Orientation (Portrait/Landscape), Columns, Rows, Margins and Spacing
options.

4 Print Options, shows you the current Driver Properties, select the
Rendering, Advanced options and the Overlay.

® Advanced Options, opens the configurations of the currently selected

Printer
Printer | g Microsoft XPS Document Witer )
Manufacturer Microsoft
Driver Microsoft XPS Document Witer
N i H
Paper Size | Letter 1 | . Dizgrticos
Dimensions 2794 mm x 215.% mm
Origntation | || Landscape .'
Prink Layout Print Options @
s = =
C\?dﬁ card Model | CR100 o3 o3 =3 Drive:
_ 4 Randering
Dimensions 85.725 mm X 53.975 mm [ L] (2] L&) Black
e a e |
Antaliasing
Ongntation Landscape f
Liss &2 = = Compesite black replacement
Columns 2 4 Advanced
:} :.: :: Invert Driver Onentabion
Fows | 4 Fotate 180
Wop Margin [0 mm Flip Herizontal
P Flip Vertical
Left Margin | 0.556 mm Use Celored Card

Print jobs
 Overlayfvammish
Honzontal Spacing |10 mm Mode

vertical Spacing 0 mm
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6.2.1 - Printer

O In this area you can choose which Printer you want to use, its Paper Size
whether it is Letter as used by A4 printers, CR-79, 80, 90 or any size
recognized by the card printer and the card Orientation.

Printer ‘ = Microsoft XPS Document Whiter

Manufacturer

Driver Microsoft XPS Document Witer

Microsoft

o

Paper Size | Letter

Dimensions 279.4 mm x 215.9 mm

Orientation‘ | | Landscape

© To view the Printers installed on your computer and their Driver version click
BOD » Printer Drivers.

Printer Drivers

£X%330

7000 U1
cxo80

oIS DCP60I
EDisecure DCPISO
Evalis Badgyl
Evols Elypso
Evalis Frimacy

Evohs Primacy (Copy 1)

[

Oriver
CIAKT CTE-640,1.4.0.5(201 2,08/05)
£%330,5.0.0.2(2010/05/20)

CX 7000 ULT.LO
CX%D80.7.0.0.2(201006710)

DS DCP3500.5.0.0.2(2010/05/10)
EDisecure DEP3S50.2.12.10.172012/10017)
Evolis Badgyl, 2.12.1.246(201 3,04 /08)
Evolis Elypso.2.12.1.254(2012/03/09)
Evalis Primacy,2.12.1.253(2012/03/09)

Evolis Primacy.2.12.1.254(201203/09)

View all cardPresso supported printers

Festore Defaults| | Save
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6.2.2 - Print Layout

@ The Print Layout settings change depending on the Card Model you
choose. In its drop-down list you can choose the Card Types available in your
Bodno Edition.

Frinter | g Brother DCP-|315W Printer " | ! 3

Manufacturer Brothar
Driver Brother DCP-|315W Printar
v Driver Options| | x|

Paper Size | Al

Dimensions 297 mm x 210 mm
Orientation | || Landscape

Print Layout Print Options:

card Model |T— Genericcombe | %) | Driver
= o I -
w Icg?g{) E Black
Onentation | « CR79 3})) - GENERIC Antialiasing
« CRBO Compasite black replacement
Columns | CRID — - # Magnetic Encode

Macros
Fows (Comman Card Ypes Charactor ancoding

i . = pdvanced
Top Margin | .. Generic Cantact Card 4

Left Margin |~ Genenc Contactless Card Invert Dnver Orientation
Al = HI-CO Fotate 180

Vertical Spacing | .- mifare Classic Flip Horizontal

Flip Wertical
Horizontal Spacing |Contact . use Calored Card
= GenencCombo Print jobs

= GenericCombo_2MagTrack
« Genenic Contact Carg " D:‘e?YNa mish
+ 12 Card ooe
v |avaCard
= SLE4442
Contactess
= GenencCombo i
= GenericCombo_2MagTrack
Generic Contactless Card
= HI-CO Mifare Classic
- 15015693 Card
= LO-CO Mifare Classic
-~ Mifare Classic
= Mifare Desfire
++ Mifare Desfire NFC
= Mifare Ultralight
Magnetic
= HICO 2Tracks
= HI-CO |2 Ok

O Different Card Models have different Print Layout settings.

In the case of paper printers you can print multiple cards in one page. Bodno
provides you with a simple grid system that you can modify to fit your printing
needs.

Print Layout lets you choose the number of rows, number of columns, top
margin, left margin, vertical and horizontal spacing. As you can see in the
image below.

1) Card Model, selects your card type.

@ Orientation, selects the orientation of your card in document.

2 Columns, number of columns.

4 Rows, number of rows.

5 Top Margin, left margin of your document.

® Lett Margin, top margin of your document.
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T Vertical Spacing, vertical spacing between cards.

8 Horizontal Spacing, horizontal spacing between cards.

Print Layout
@ cardModel | = crso | e e2 e
Dimensions 85.725 mm x 53.975 mm . ra [
. el el bl
. Grientatiun| [ Landscape . _— _
d ea s [
® columns i
(A (] [
@ roe
. Top Margin|t} rrm -::|
. Left Margin |D.556 mm -:':|
1  Vertical Spacing |D mm = :|
Heorizontal Spacing |1D mm = :| 8
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6.2.3 - Options

@ The Print Options section contains information and configuration settings
on how the print job is sent to the printer Driver.

Print Options

» Driver

: Rendering

> Advanced

» Overlay/Varnish

@ The Driver section shows the basic driver info of the printer currently
selected.

Print Options

4 Driver -
4 Manufacturer
Windows (R) Win 7 DDK provider
4 Mame
Matica Printer Driver
4Version
6.1.7600
4 Class
Matica Espresso
a Model
Matica Espresso
4 Print Class
WIN32API

4 Print Test
Print Test

Dandarioa

@ The Rendering settings allows you to configure advanced Black rendering
options, Antialiasing, and Composite Black Replacement.
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Print Options

- Driver
4 Rendering
4 Black
Separate Render
4 Antialiasing
fes
4 Composite black replacement
Disabled

. Advanced
- Overlay/vVarnish

Black - configures how the black color is sent to the printer. You can Send as
RGB; Send as Monochrome; Send as RGB and Monochrome; Send
Composite; Send Composite and Monochrome or send as a Separate
Render (default option).

Antialiasing - lets you enable or disable Antialiasing for either the whole card,
Text only and for Images only.By default, the option is active.

Composite black replacement - You can use composite black replacement
with one of the following options: Using the options available: Grayscale (Low,
Medium or High), Color Decrement (Low, Medium or High) Red Increment (Low,
Medium or High).

Black - To obtain the desired results, you can submit the black in RGB;
monochrome; RGB and monochrome; composite; composite and monochrome
and separate render.

Composite black replacement - You can activate composite black
replacement, using the options available: Grayscale (Low, Medium or High),
Color Decrement (Low, Medium or High) Red Increment (Low, Medium or High).

@ The Advanced section provides you with the following options.
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Print Options
|+ Advanced =]
4 Rotate 180 |
Mo I
4 Flip Horizontal _ |
Mo |
4 Flip Vertical
Mo

4 Use Colored Card _ ‘
Mo ‘

| 4print jobs
All Print operation !

Rotate 180, Rotates the layout by 180° when sending the print job.
Flip Horizontal, Flips the layout horizontally when sending the print job.
Flip Vertical, Flips the layout vertically when sending the print job.

Use Colored Card, Sends the print job optimized for when your card is other
than white.

You can select from Black, Green and Yellow.

Print Jobs, By default the print job is sent as "All Print operations", in this
case Bodno sends all print jobs whether each print job was successful or not.

With Card by Card option Bodno only sends the next card to be printed, after
receiving a success signal from the printer.

With Card by Card and Wait option Bodno sends the print job one by one,
and waits for a user input. Bodno will wait for a user confirmation that each
selected print job is successful before sending the next print job.

Overlay/Varnish:

Mode: By default the Overlay is Disabled. Depending on the Printer in use it is
possible to send the Overlay Layout during the print job to the driver by saving it
to an External file or directly to the printer as Separate Page.

© 2018 Bodno



172 Bodno Manual

Print Options

I Driver

> Rendering

- Advanced

4 Overlay/Vamish
a Mode

. Disabled
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Chapter 7. Encoding

@ Bodno's other core function is encoding. The process of encoding consists
in converting information from one format to another, and in the context of
Bodno, storing that information in a card.

To that end Bodno provides you with a dedicated workspace stocked with tools
focused solely on Encoding and managing the way information is sent to your
card.

This workspace is called Encode View.

7.1 - Encode View

@ The Encode View is where you view manage the encoded information in
your card and the encoding operations to be performed when encoding to your
cards.

You can access it by clicking the Encode View button, or through the menu
View > Encode View.

This section gives you access to the various sections that manage the encoding
process.

The Encode Model window shows a visual representation of the way data is
stored in each card.

The Data Inspector window shows the data currently being browsed in the
Encode Data window.

The Encode Script window shows the encode commands that run when the
card is encoded.

The Properties window, to the right, has its own set of options in the
Properties section which provide you with convenient information and tools to
make Encoding fast and easy.
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7.2 - Encode Model

@ The Encode Data window is a visual representation of the way information is
stored in your card. It allows you to easily browse the card for a quick access to
the information stored.

You can find it by clicking the Encode View button.
Different Card Types have different types of Encode Data organization.

Here is an example of the Encode Data window of a Mifare card:
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s Mifare Classic 1K
» Sector 0
» Sector 1
» Sector 2
» Sector 3
» Sectord
» Sector 5
> Sector B
» Sector 7
+ Sector 8
» Sector 9
» Sector 10
» Sector 11

Sector 12
Block 0

iBlock 1
Block 2

< Trailer 12
» Sector 13
> Sector 14
» Sector 15

7.3 - Data Inspector

@ The Data Inspector window shows you the data currently stored on the item
you select on the Encode Data window and allows you to manipulate the stored
data. This gives you a quick reference of the data stored in your card and
eases the workflow while working on your Encode Operations.

You can find the Data Inspector window by o clicking the Encode View
button, or clicking View > Encode View.

The information shown on Data Inspector also changes depending on the Card
Type.

The Data Inspector window organizes the information stored in your card in 3
columns:

Block shows the card block currently selected in the Encode Data window.

Hexadecimal shows the hexadecimal value of the data currently stored on the
selected card block.

If the user has changed the value using the Edit button, it will show the new
value entered by the user)
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ASCII shows the value of the Hexadecimal field in regular text format.

Here is an example of the Data Inspector window of a Mifare card where we
wrote the hexadecimal value for the word "Bodno":

Mifare Classic:Block 2

Block Hexadecimal ASCI
S00B02 [536FEEE961204461766F6CE96F000000 | Sonia Davolio...

Continuous F_ead

@ The Data Inspector window comes with a set of tools that allow you to
quickly view and modify the data stored in your card:

The Edit button allows you to directly modify the information stored in the item
currently selected in the Encode Data window. The Edit button works with
Hexadecimal values.

The information will only be written in the card when you press the Write button.

Hexadecimal

|535F5E69512l}4451?55FECEQEFHHHHGH

ASCI

|Sunia Davolio... |

[ oK |[ Cancel |

The Read button allows you to read the information stored in the item currently
selected in the Encode Data window.

The Write button writes in the card the value currently visible in the
Hexadecimal separator of the item currently selected in the Encode Data
window.

The Continuous Read button makes Bodno repeatedly read the data in the
currently selected item every two seconds.

This allows you to perform several write functions in the Encode Operations
window and immediately see the results on the Data Inspector window.
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7.4 - Encode Script

@ The Encode Script window is where all the codes that manipulate how
information pertaining to your card is written. You can program and test all the
encoding actions you want before printing through this window.

You can find the Encode Script window by Q clicking the Encode View
button, or clicking View > Encode View.

The actions written here will then occur each time the card is encoded.

Here is an example of the Encode Operations window of a Mifare card type:

Contactless encoders | OMNIKEY CardMan 5x21-CL 0 )

/f The Mifare UID is read in Hexadecimal and ordered by the MSBE "Most significant Bit”
{reading the bits from left to the right)

{i Bodno reads the UID using » card.UID

ji to read the UID in LSE "Least Significant Bit" use » card. UID _LSE

Jf to read the UID in Decimal (0-8) use » parselnticard.UID, 16)

/f Mifare cards have 2 keys: A and B. normally the keys are all 'F

Jt if there is a » Error: mifare:Error readMifare:PSSC ERROR:6982:Security status not satisfied
Line: XX « this means that the key is wrong.

{f The comand below sends an all 'F* key ‘A’

mifare key{"A" "FFFFFFFFFFFFY);

{f Read and White to a Block of the card

Ji write to HEX in sector X block ¥
.n'fmjfare.writeli)(.‘f."'i-’-lﬁﬁ?3?4 207772697465000000000000", "HEX");

ji from the connected Database
jimifarewrite( X, Y. currentRecord["Hire Date").toString());

Il Simple text write
mifare.wnte!{s.2,"cardPresso®);
|

all 1 |
|

—

Contactless I Output O
528689735

© By default the Encode Operations window comes with some commented
basic sample code to get you started on the most common Encode Operations
of the selected card type.

If a line is commented the code it contains will not run under any circumstance.
To run you must remove the comment tag ( // ) in the beginning of the line).
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In  the previous example the line  containing the  code
"mifare.write(5,2"Bodno");" is the only one that will run because it's the only
code line that is not commented.

The various Encode Operations also change with each Card Type.

7.5 - Properties

@ The Encode View also has it's own set of Properties tabs located as usual
to the right. It provides you with several separators which contain convenient
information about your card, your printer, your users, your database and
scripts. All with more tools to make your Encoding Operations even smoother
and easier to implement.

You can find the Encode View Properties tab by Q clicking the Encode View
button, or clicking View > Encode View.

7.5.1 - Preview
© The Preview tab provides you with a quick overlook on the card design. You
can swap between the front and the back of the card design preview by clicking
the Front button and Back button respectively.

You can find the Preview tab by o clicking the Encode View button, or
clicking View > Encode View and clicking the Prevew tab on the right.

Preview l

SHOPPING |

=
]
=
.
]
4
C
=
o

Lser Data

Front Back

Database
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7.5.2 - Printer Tools

© Printer Tools are a powerful set of tools that allow you to manually navigate
your card inside your printer (in printers that support these functions) so you
have more control over how your printer uses your card while writing your
Encode Operations.

The available printer tools vary with the printer modules installed on your printer.

You can find the Printer Tools tab by o clicking the Encode View button, or

Q clicking View > Encode View and clicking the Printer Tools tab on the
right.

Insert card from card input feeder inserts a card positioned in the printer
input feeder into the printer circuit.

Insert card manually allows you to manually insert the card directly in the
position you desire.

Position card at contact encoding unit moves the card from its current
position to the contact encoding unit.

Position card at contactless encoding unit moves the card from its current
position to the contactless encoding unit.

Move card out of contactless encoding unit moves the card out of the
contactless encoding unit.

Eject card to dispenser unit moves the card from it's current position to the
card dispenser unit.

Eject card to reject unit moves the card from it's current position to the card
dispenser unit.

Magnetic Encoder allows you to read the content the 3 tracks of a magnetic
card.

Direct Commands allows you to send commands directly to the printers who
support this feature (please refer to the printer manufacturer for a list of
supported commands).
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© These options work only with printers that support commands.
7.5.3 - Database

@ The Database separator works Encode View exactly the same way as in
the other views. You can browse your records, edit them and drag them into the
Encode Operations window. Making your work with Encode Operations in
Bodno even easier and faster!

You can find the Database tab by o clicking the Encode View button, or o
clicking View > Encode View and clicking the Database tab on the right.
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Prewview

Table Employee
Record 1 of 15

|

w
8
E
Tt
1]
Furt
=
s
o

Employee Id
L 1/
Supervisor Id
5

User Data

Last Name

|Davolio

First Mame

Database

[sonia
Position

[Sales Representative |

Database Filter

Birth Date

|1972/12/08 (00:00:00) =
Hire Date

|1991/03/29 (00:00:00) |

s}
I
=
w
w
o
0
[
e}
[
[m}

Home Phone

[(206)555-9857

Extension

MNotes

| a member of Toastmasters International. |
-
(] | [+

7.5.4 - Database Filter

@ Database Filter is yet another strong tool that makes the work-flow on
Encoding Operations much smoother and faster in Bodno.

You can apply Database Filters on Bodno so you only see the records with
the information that matters the most to you. Making browsing database records
a much easier and cleaner task.

You can find the Database Filter tab by clicking the Encode View button, or
clicking View > Encode View and clicking the Database Filter tab on the right.

To do so, simply select the column which contains the data you want to filter.
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Select the condition to filter which matches your needs.
Insert the value you want to filter

Select Add Condition and click Apply (You can add more filters by selecting
And or Or).

Now when you browse your database records on the Database tab, only those
that follow the condition will show.

Database

Preview

Table Employee
Record 1 of 15

Conditiens,

| Position ] E]

| Is Equal {=)

wl
o
fis]
-
{1F]
=
{4
o
o

|5ales

| User Data

| And

| Extension ] B

| Database

| Is Equal {=)

(5467

| Add Condition ...

sqL

Database Filter

*Position” = 'Sales' AND " Extension’ =
5467

Database Find

7.5.5 - Database Find

€@ Database Find is a quick reference tool that lets you find specific values
throughout your database.

You can find the Database Find tab by clicking the Encode View button, or
clicking View > Encode View and clicking the Database Find tab on the right.

Select the Column in which you want to find a value.
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Select the condition that fits your situation.
Insert the value you want to search for.

Use the buttons to navigate through the records which comply with the condition.

Database

Praview

Fecord 5 of 15
Table Employee

Find,

il
S
|_
L
]
T
f=
=
o

| Employee ID

| Is Equal

User Data

Database

Found in record:5

7.5.6 - Script

@ The Script separator is the Document script and if you previously added
code, it will be located here. See more on Chapter 4.4.12 - Script.
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Chapter 8. Users

€ When working with multiple collaborators, managing and providing select
permissions to each individual becomes crucial.

Users is yet another powerful management tool provided with Bodno to help
you specifically with user management, allowing you to limit who can access
Bodno and what they can do.

Users provides you with tools that allow you to create and manage user logins
for Bodno. This gives you full control over who has access to Bodno and what
they can do. With the added ability to create groups, managing large numbers
of users becomes as simple as a single click.

8.1 - Users View

@ The Users View gives you access to all the tools that allow you browse, add,
remove and edit Users and Groups. It also gives you access to an overview of
all their operations and an additional option to print customized audits.

You can access the Users View by clicking Window > Users View:
The Users View is separated in 5 smaller sections:

The Users View Toolbar provides you with the basic tools to add and remove
users, add and remove groups and print audit reports:

Audit Report  Prints an Audit Report for different files formats.

Add User Creates a new user.

B Remove User emoves the user currently selected in the Users
section.

Add Group Creates a new group.

% Remove Group Rempves the user currently selected in the Users
section.

Refresh Views Reloads the users database on the Users View.

@ The Users section located in the top left of the Users Vew shows a list with
all the users you currently have configured in Bodno.
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Users

Login Name
ADMIN Administrator
|OADLUCAS |odo Lucas

NMUMOMARTING  MNuno Martins
PEDROSOUSA Pedro Sousa
RUIFARIA Rui Faria
SARANVAT Sara Vaz

© The Groups section shows you a list with all the groups you currently have
configured in Bodno and it's respective users.

Groups
Group Name Users
ADMIMN Administrators ADMIN,RUIFARIA
PRINTONLY Print Only PEDROSOUSA,SARAVAZ
VIEWONLY  View Only JOAOLUCAS NUNOMARTING

The Auditing section is located in the bottom half of the Users View and it
shows a list of all the actions performed by each user.

@ You must first enable auditing for the intended users in the User Properties
tab by editing the user (see more on: Chapter 8.2.5 Edit a User).

Auditing

Date Computer Location Operation User Decument  Description  Event Result
2013-12-16 13:17:01 CPPEDROSOUSARC Lsers View ADMIN
2013-12-16 13:16:58 CPPEDROSOUSAPRC New Document  ADMIN Cocurmantl
2013-12-16 13:16:37 CPPEDROSOUSARC Wilcorme view ADMIN
2013-12-16 13:16:52 CPPEDROSOUSAPC Refresh Views  ADMIN
2013-12-16 13:15:55 CPPEDROSOUSAPC Users View ADMIN
2013-12-16 13:15:51 CPPECROSOUSAPC Welcame view  ADMIN
2013-12-16 13:15:42 CPPEDROSOUSAPC HQ Exit PEDROSOUSA
2013-12-16 13:15:41 CPPEDROSOUSARC HQ Save Document PEDROSOUSA Cardl
2013-12-16 13:15:20 CPPEDROSOUSAPC HQ Mew Text PEDROSOUSA Docurnentl
2013-12-16 1%:15:23 CPPEDROSOUSAPC HQ Mew Text PEDROSOUSA Documentl
2013-12-16 13:15:17 CPPEDROSOUSAPC HQ New Text PEDROSOUSA Documentl
2013-12-16 13:15:15 CPPEDROSOUSAPC HQ New Document PEDROSOUSA Documentl
2013-12-16 13:15:12 CPPEDROSOUSAPE HQ Welcome view  PEDROSOUSA

The Properties tab is located as always to the right of the Users View. It's
contents also change depending on what you are currently doing, whether it's
adding new users and groups or editing their respective settings, all the
information is shown and edited here.
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o EDIT USER
~
Login ADM
g 0 -
o Name Administrator
a
5 Password L 11 1T 1111110117}

Confirm Password 99 0000000000000
[ Disable user {cannot login)
Enable auditing

@ Above is the properties tab while a user is selected.

8.2 - Users

© A User system is a combination of a user name and a password and, if
enabled, are required to access Bodno. The user name and password identify
each person that accesses Bodno and determines what they can or can not do
within Bodno by attributing each user with its own set of permissions.

8.2.1 - Enabling User Logins_2

@ The first step to work with users is enabling user logins. You can do this by
accessing the Users View by clicking the Bodno menu Window > Users
View and in the bottom of the window clicking the Enable user logins
checkbox.

The first time you enable user logins, you will be prompted with the default user
name and password.

The default user name is ADMIN and the default password is admin:

This information will only appear once.
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Onthe nexttimeyourun
software you will be asked to enter your
username and password.

’('. The default user name is ADMIN and the
£ default password is admin.

Close

Enable user logins

8.2.2 - Login

@ After enabling users logins, when you open Bodno you will be required to
enter the login credentials on the welcome screen.

Simply type the credentials and © click the OK button.

User Mame |ADMIMN
’(. I |
- Password |@@@@® |

Change Password | ok || cancel

Every user that is created can login in this fashion.
8.2.3 - Add User

@ With user logins enabled the next step to managing your users is adding
them. You do this by clicking the Add User button found in the Users View
Toolbar.
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Doing so will open the new user options in the properties tab where you will be
prompted to fill various fields required to create a new user:

ADD USER
Lﬂgir'l PEDROSOUSA
Mame Pedro Sousa

Password 20080
Confirm Password @@ @ee@®

|f User Properties |

[ Disable user (cannot login)
[ Enable auditing

Save
Login: Write the user name the user must insert when logging in Bodno.
Name: Write the name of the owner of this user name.
Password: Write the password the user must insert when logging in Bodno.
Confirm Password: Repeat the password to validate it.

Diable user (cannot login): The user won't be able to log in Bodno until this
option is disabled (unchecked).

Enable auditing: Every user action within Bodno will be recorded and visible in
the Auditing section.

© Click Save to save the new user. It will then be available for editing in the
Users section.

O A new user will have no permissions until assigned to a Group (see more on
Chapter 8.3.2 Add Group).

8.2.4 - Remove User

@ To keep a clean and up to date user base you can remove Users that are no
longer needed by selecting the user you want to remove and clicking the
Remove User button found in the Users View Toolbar.

If a user is removed its user name and password will no longer work when
logging in losing all access to Bodno.
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LUsers
Login Name
ADMIMN Administrator
Delete user
JOAOLUCAS Jodo Lucas

NMUMNOMARTING  MNuno Martins

[PEDROSOUSA  Pedro Sousa | Do you want to delete

BUIFARIA Bui Faria user PEDROSOUSA 7
SARAVAZ Sara Vaz Yes Cancel

@ Removing a user is a permanent action that cannot be undone.

8.2.5 - Edit a User

@ To edit an existing User select the user you want to edit in the Users section
on the Edit Vew:

Users

Login Name
ADMIMN Administrator
JOADLUCAS Joao Lucas

NUNOMARTING  MNuno Martins

RUIFARLA Fui Faria
SARAVAYF Sara Vaz
TEST test

Once selected, the user's data will be editable in the properties window to the

right:
@ EDIT USER
.
=% Login PEDROSOUSA
& Name \Pedro Rocha |
a
45 Password 000000000000000

Confirm Password (9@ 0000000000008 |
[ pisable user (cannot login)
Enable auditing

Save |
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When done editing, to save the changes © click the Save button.

@ Once created, the user Login field cannot be edited.

8.3 - Groups

@ Bodno adds Groups to its User management system to ease editing large
numbers of users.

Here you can add Groups and select each group's specific permissions and
assign them to multiple users.

When a User is assigned to a Group, it inherits all the permissions the Group
currently has. Every change to the group's permissions affects the permissions
of all the users assigned to it.

© A user with no group assigned will have no permissions.
8.3.1 - Add Group

@ To add a Group O click the Add Group button found in the Users View
Toolbar.

Doing so will open the new group options in the properties tab where you will be
prompted to fill various fields required to create a new group:
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@ ADD GROUP
i
a
Grou
CEL e
0. MName
o
= i 5
o Location |
£ ;.
 Users
] ADMIN Administrator

] JoAOLUCAS  |odo Lucas
[] NUNOMARTINGS Nuno Martins
[] PEDROSOUSA Pedro Sousa
[] RUIFARLA Fui Faria

[] SARAVAZ Sara Vaz

Permissions

4 Design

» 7] Fle

> [0 Edit

» [ View

> ] Tool

> [W] Help
4 Database

» [¥] Database
4 ser Logins

» [0 Users
4 DockBars

» Document

» Users

Group*: Write the unique name Bodno will use to identify the group.
Name: Write the name of the Group for easier identification.

Location: Write the name of the location / department / category of the users
assigned to this group.

Users: Select the Users that belong to this group.

© One user can belong to more than one group.

Permissions: Select the permissions that the users assigned this group will
have.
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© Click the Save button to save the group with the selected settings.

*required field

8.3.2 - Remove Group

@ If a group is no longer needed you can remove it by selecting the Group
you want to remove and clicking the Remove Group button found in the Users
View Toolbar.

If a group is removed all users assigned to it will lose all permissions the Group

had.
Groups
Group Name Users
ADMIN Administrators ADMIN,"
[ESHORSIEGESEIMMNEEDD| *°°°
PRINTONLY Print Only SARAVE
VIEWONLY  View Only JoADLU

Do you want to delete
the group EDITORS ?

Yesg Cancel |

@ Removing a group is a permanent action that cannot be undone.

8.3.3 - Edit a Group

@ To edit an existing Group select the group you want to edit in the Group
section on the Edit Vew:

Groups
Group Name Users
ADMIN Administrators  ADMIN,RUIFARIA
PRINTOMLY Print Only SARAVAZ
VIEWONLY  View Only JOAQLUCAS, NUNOMARTING
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properties window to the right:

|J Group Properties l
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and permissions will be editable in the

EDIT GROUP
Group EDITORS
Name |Editors
Location [HQ
Users
[ ADMIN Administrator

[] JoAOLUCAS

[] RUIFARLA Fui Faria
[[] sARAVAZ Sara Vaz
] TEST test

Jodo Lucas
[ NUNOMARTINS MNuno Martins
[¥] PEDROSOUSA Pedro Sousa

Permissions

4 Design

» [#] File

> W] Edit

> [F] Wiew

» [#] Tool

» [¥] Help
4 Database

» [#] Database
4 User Logins

» ] Users
4 DockBars

» Document

» Users

When done editing, to save the changes click the Save button.

@ Once created, the user Group field cannot be edited.

8.4 - Auditing

@ The Auditing section in Users View is where you can see every action
performed by any user in Bodno.

© 2018 Bodno



m Bodno Manual

To audit a user you must first Enable Auditing for the intended user in the User
Properties tab by editing the user (see more on: Chapter 8.2.5 Edit a User).

After enabling auditing for a user every future action that user performs in

Bodno is registered and listed in the Auditing section.

Auditing
Date

2013-12-16 20:12:35
2013-12-16 20:12:32
2013-12-16 20:12:22
2012-12-16 20:12:15
2013-12-16 20:11:39
2013-12-16 20:11:53
2013-12-16 20:11:49
2013-12-16 20:11:37
2013-12-16 20:11:34
2013-12-16 20:11:31
2012-12-16 20:11:28
2013-12-16 20:11:22
2013-12-16 20:11:09
2013-12-16 20:11:05
2013-12-16 20:10:53
2013-12-16 20:10:47

Camputar
CPPEDROSOUSARC
CPPEDROSOQUSAPC
CPPEDROSOQUSARC
CRPEDROSOQUSARC
CPPEDROSQUSAPC
CPPEDROSOUSAPC
CPPEDROSOUSAPC
CPPEDROSOUSAPC
CPPEDROSOUSAPRC
CPPEDROSCUSAPC
CPPEDROSOQUSAPC
CPPEDROSOQUSARC
CPPEDROSQUSAPC
CPPEDROSOUSAPC
CRREDROSOUSARC
CPPEDROSOUSAPC

Location

HQ
HQ
HQ
HQ
HQ
HQ
HQ
HQ
HQ
HQ

8.4.1 - Audit Report_2

Operation
Users View
Welcome view
Ext
Save Documeant As
Save Document
Mew Rectangle
New Circle
Mew Image
Browse Image
Delete
Open Document
wielcome view
Exit
Save Document
Connect to database
Delete

User

ADMIMN

ADMIN
PEDROSOUSA
PEDROSOUSA
PEDROSOUSA
PEDROSOUSA
PEDROSOUSA
PEDROSOUSA
PEDROSOUSA
PEDROSOUSA
PEDROSOUSA
PEDROSOUSA
RLIFARLA
RUIFARIA
RLIFARLA
RUIFARIA

Document

Sales Card
MyCardl
MyCardl
MyCardl
MyCardl
MyCardl
MyCardl
MyCardl

MyCardl
Documentl

Documentl

@ For an easier view purposes Bodno allows you to print or export
customizable Auditing Reports.
You can do this by clicking the Audit Report button on the Users View

Toolbar.

Doing so will open the Audit Report editor window, where you can customize

your reports before printing or exporting them to files.

From date

To date
From time
To time
Computer
Location
Operation
User
Group

Document

Order

Output to

Description

Event Result

Report model

01-01-2000

31-12-2100

00:00:00

23:59:59

| All Computers

| All Locations

Lol

| All Operations

| All Users

; All Groups

| All Documents

*

*

| eventDate

| auditModel

| PDF File

oK Cancel
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Appendix A - DIAMOND Net License

To use this service, one computer must have the Bodno DIAMOND Edition
USB dongle and be connected to the same LAN as the other computers. When
the Net License service is activated on this computer, it acts as the Server and
provides the license to a total of 15 computers connected to the same LAN.

@ The Bodno Net License Service only works on a LAN. It does not work
through the internet.

use (EEEIND
- B
]

-8

Switch —
10.10.10.X

O For best results, the computer with the Net License Service should have a
Static IP Address. The computer acting as the Net License "Server" does not
need to have a Server type Operating System.

To ensure the Net License Service is always available to the other computers,
the USB dongle should be connected to a computer that is either always turned
on, or at least when the other computers require the Net License Service.
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Appendix A.1 - Installing the DIAMOND Net License Service

© To install Bodno's Net License service please do the following:

1 - Install Bodno on the computers but without the service.

Please select installation folder or choose Evaluate to
run program without installation

Shortcuts Install in programs folder

o | B Install security service
Finish ; e

B Select destination folder

Install for all users

2 - In the computer that will run the service and act as the server, open the
Bodno menu BOD>Bodno License.

File Window Help

About Bodno

Clear Config

USB Devices

View Folders

Printer Drivers

Language »
Use Default System Font

Registration

3 -In the Bodno License window, click the Net tab click on the Run as
Application button:
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USE Met

License server

security service not installed

Fun as Application § Install as Service

Close

@ On systems using Windows Firewall, a warning will pop-up, please allow the
Bodno connection through the Local Area Network.

@ Some Firewall applications will not show any warnings and automatically
block the License Service, the required permissions are at the end of these
instructions.

This will open a command line window which will show you if the ports are open
and if a Bodno application is running in the network.

runStart
nectio

ldFile<F:
dlolumeFiles
thread: :ENUM.sto

ction accepted:=192.168.2.1364
_enumerateDevices: -
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In this example:
192.168.2.138 is the Host computer acting as a Net License server, providing

the license.
192.168.2.136 is the Client computer receiving the license.

4 - Close the BodnoLS.exe window and click Install as Service

use Met

License server

security service not installed

Fun as Application Ilnstall as Service|

Close |

5 - Run the service and confirm it's running.

USB Met

License server

security service is not running

Close |
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USBE Met

License server

[ securty service is running ]

| Close

6 - In the License Service Client Computer use the default configurations or
change it based on your networks characteristics.

USE Met

License server browser

[Use'h'\.indnws WINSand _____ _ NE |~
Use Windows VWNS
Use Windows WINSand ___ _ _ _ NENS

Use known static address

Disable Y
P—— r — Apply

Close |

Now you can have up to 16 computers in your Local Area Network, including
the one acting as a server, running Bodno <% EDXXLEQUIV% >edition.

@ If Bodno doesn't automatically detect the license in a Client computer, open
a command prompt window (Start Menu > Run> cmd.exe) type "ping
Bodno_LS" and hit return.
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If the host isn't found as shown above, please confirm that it is in the same Local
Area Network, and if so, open a port in the firewall for:
CPSECURITY_SERVICENAME "Bodno_LS"

CPSECURITY_SERVICEPORT 1947

(TCP to communicate and UDP for the name)

If the ping requests an answer from an IP address that doesn't belong to the
Local Area Network and has no answer, retest the ping after rebooting the
Router and/or use a different router.

@ Warning : If the License Service is added (Step 3) to multiple computers, a
License Service "cluster” is created and it will drown the real License Server.

Also, the Net License uses WINS or NetBios to assign the License to the client
computers. Therefore the License won't be assigned to a Bodno application
outside the WINS or NetBios range.
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Appendix B - Advanced Print Operations

@ Bodno contains several advanced features to provide you with the flexibility
required to adapt to any circumstance.

In this chapter we will show you an overview on which features are available,
how they work, and how to best use them to make your printing jobs simple, fast
and most importantly, exactly the way you want them.

Appendix B.1 - Overlay

@ By default Bodno uses the printer's default overlay pattern. However Bodno
also gives you other options regarding how you work with the Overlay ("O"
Ribbon).

You can access the Overlay options through the Bodno menu File>Print
Settings.

Bodno gives you three options:

1 - Separate Page lets you design your own Overlay with Bodno's Design
Vew.

2 - External File lets you design an Overlay within Bodno so later when printing
it can be used through your printer's driver settings.

3 - Use the printer's default overlay pattern by disabling Bodno's overlay
customization.

Important notes regarding how printers work with Overlay:

@ Printers which support overlay printing have their own overlay settings.
These settings override Bodno's settings. This means the printer's settings
determine if the overlay is printed or not, regardless of Bodno's configuration.

You can find your printer settings on the Printer Options through the Bodno
menu File>Print Settings, Driver Options button.

@ Bodno can only print overlay if the printer being used supports overlay
ribbons, has an overlay ribbon installed and has the overlay option enabled in
it's own Driver Options.

© If the overlay option is Disabled in Bodno but the printer Driver Options
have overlay enabled, the printer will still print overlay.

O If an overlay option is enabled in Bodno but the printer Driver Options have
overlay disabled, the printer will not print overlay.
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@ To prevent unintentional Overlay printing, we recommend disabling the
Overlay printing option on your printer driver settings while designing your
Overlay. Enable it only it when you are ready to print.

Appendix B.1.1 - Separate Page Overlay

@ One of the ways Bodno allows you to customize your own Overlay is by
providing you with a separate page within Bodno where you can design your
Overlay the same way you design your cards.

This option is found through the Bodno menu File>Print Settings, Print
Options>Overlay/Varnish>Mode>Separate Page.

When this option is selected, below it, you will have access to another setting:

Side: Lets you choose the side of the card where the Overlay is to be printed.
You can choose either Front or Back.

Print Options

- Driver
- Rendering
4 Advanced
- Invert Driver Orientation
: Rotate 180
 Flip Horizontal
- Flip Vertical
- Use Colored Card
» Print Jobs
4 Overlayf/Varnish
4 Mode
Separate Page
+side
Front |

Once Separate Page is enabled, Bodno will display an Overlay/Varnish tab in
the bottom left corner of the Design View as shown highlighted in the image
below:
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REFEREEBREE"ON0 B g*

When you click this tab you will have all the design tools Bodno provides to
design your own Overlay.

6 The Overlay/Varnish page can only be printed with the Overlay Ribbon.

Appendix B.1.2 - External File Overlay

@ External file lets you design an Overlay within Bodno and then export it as
an image file so you can open it through your printer's driver configuration. This
way your printer will print all images with the selected image as the Overlay
design.

This option is found through the Bodno menu File>Print Settings, Print
Options>Overlay/Varnish>Mode>External File.

When this option is selected, below it, you will have access to more settings:

File: Lets you save your Overlay/Varnish design to a .bmp file, to later be used
by your printer driver when printing.

Side: Lets you choose the side of the card where the Overlay is to be printed.
You can choose either Front or Back.
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Print Options

I Driver
I Rendering
4 Advanced
I Inwert Driver Orientation
[ Rotate 180
> Flip Horizontal
i Flip Vertical
i Use Colored Card
i Print Jobs
4 Overlay/Varnish

llaries,fMy Pictures/Overlaybmp [
4 Side

Front [ » |

Once External File is enabled, Bodno will display an Overlay/Varnish tab in
the bottom left corner of the Design View as shown highlighted in the image
below.

You can then open the Overlay/Varnish tab and use Bodno's design tools to
design your own Overlay.
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* Fle Edt viesw TJool Database Wndow Help
HMEEEE DcEE AAR E & -
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|

EPERBEEBRE 0Nl £

62 Backgrounds tound, 0 folders rermaining

l Dusign | Cwerdayvamish | |
e e re——r |

After you finish designing your overlay in the Overlay/Varnish tab, you can use
the Overlay File button in the Print Options shown above to save your design
to a .bmp file.

Access your printer driver options and confirm that the correct options are
marked, according to the printer you are using. Always return to the Design tab,
so that you are viewing your Layout Design instead of your Overlay design,
before printing.

Appendix B.1.3 - Printer Default Overlay

@ By default the printers which support overlay have their own overlay design.
The third (and default) Overlay Mode option is Disabled. When this option is
selected Bodno lets the printer use it's default Overlay design.

This option is found through the Bodno menu File>Print Settings, Print
Options>Overlay/Varnish>Mode>Disabled.

When this option is selected, no more options are available and Bodno will not
send any overlay designs to the printer.

When printing, the printer will either not print overlay if the option is disabled on
the printer settings, or it will print overlay using it's default design enabled on the
printer settings.
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Appendix B.1.4 - IDP SMART 50 Overlay Settings

@ The way the IDP Smart 50 printer works with Overlay requires the following
configuration:

Print Options

3

» Rotate 180
- Flip Horizontal
' Flip Vertical
- Use Colored Card
- Print Jobs
a Overlay/Varnish
4 Mode

External file

File
- Side
4 Format
24-Bits per pixel

w

The RGB value of objects in a “user defined mask” is the factor that SMART
uses to distinguish which panel is used.

R value is for the Overlay (O) panel

G value is for the printing (YMCK) panel

B value is for Fluorescent (F) panel.

Value “0” means ‘activated’ and value “255” means 'deactivated'.

© Examples:

- Blue = RGB(0, 0, 255) : printing and Overlay

- Pink = RGB (255, 0, 255) : printing only

- Black = RGB(0, 0, 0) : printing, Overlay and UV printing
- Red = RGB (255, 0, 0) : printing and UV printing

Appendix B.2 - Web Print Server

@ The Web Print Server alllows you to remotely print cards from a computer
that doesn't have Bodno installed.

To use the WebPrint Server you are required to:

1 - Have a computer with Bodno DIAMOND Edition connected to a working
local area network (LAN or Internet) to act as the Web Print Server.

2 - Have another computer (Client Computer) connected and to the same local
area network (LAN or Internet).
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3 - Use an external application on the Client Computer to send the Print Job
through IP to the server. The Print Job format must comply to the standard we
provide in our website, available for download here.

0To use this service, the Web Print Server computer with the Bodno DIAMOND Edition

USB dongle must be accessible to the Client Computer via IP connection either through a
LAN or an Internet connection.

Appendix B.2.1 - Configuring a Web Print Server

@ The first step to use the Web Print Server service is configuring the
computer that will be running Bodno and receiving the print jobs.

To configure the Web Print Server you must:

1 - Save the card file you wish to print remotely on the My Cards folder:

File pame: ST IE -
Save as type: ;DGCUMENTS (*.card) o
¥ Browse Folders Save I Cancel I

1 - Create a copy or use an existing Bodno windows shortcut, right click it and
select Properties.

Create shortcut
Delete

Rename

Properties

NS

2 - Add the /PRINTSERVER switch to the shortcut Target after the quotation
mark and click OK:
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Security | Details I Previous Versions
General | Shortcut | Compatibiity
r;-} i E..

Target type: Application

Target location: cardPresso

Target: v /PRINTSERVEH

Start in:

Shortcut key:  Mone

Bun: I Momal window - I
Comment:
Open File Location ] I Change lcon... ] [ Advanced... I
i OK i I Cancel ] Apply

3 - Open Bodno as a Web Print Server with the new shortcut.

4 - On the Web Print Server window you must configure:
The IP Address of the computer acting as the Web Print Server.
The Port Bodno should use to receive print jobs.

The User Groups (see more on Chapter 8.3) that can access the Web Print
Server.

When all the settings are configured, press the Save button to save the changes

and press the green Start Service button, on the bottom right to start the Web
Print Server.

If correctly configured, the button will turn red and the Status box will display a
listen OK message as shown below:
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Listen: Allowed user groups
Address: |¥| Administrators
_ 127.0.0.172 [¥] Editors
AR e Port: [¥] Print Only
Save

Status:
listen OK (127.0.0.172:632)

@)

Close

Your Web Print Server is now running and has a .card file ready to be printed.

O when working within a LAN (Local Area Network) the WebPrint Server computer must
be connected to the same network as the Client computer that will send the remote print
jobs.

O when working through an internet connection, both the WebPrint Server computer and
the Client computer must be accessible to each other through a TCP/IP connection.
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Appendix B.2.2 - Print XML Structure

© Wwith the Web Print Server configured and ready to recieve print jobs the
last step to print using this service is sending a print job to the server.

The transmission of print jobs to the web print server will be handled by a user
developed application (see sample application files in Appendix B.2.4 - Sample
Files for the Web Print Server

The print job data must be sent to the Web Print Server in an XML structured
document. A complete XML sample is available for visualization in Appendix
B.2.3 - Web Print Job XML Sample.

The XML strucure of a print job requires the following elements:

The Bodno element specifies the beginning of a Bodno Web Print Server
document. It must always contain a login element and a cardDocument
element.

The login element contains the user name and password elements. Each
specific to the user configuration in the Bodno Web Print Server application.
These elements are mandatory.

The cardDocument element contains properties and elements with the data
specific to the print job.

The cardDocument element contains three attributes:

The filename attribute specifies the name of the .card document file to be used
in the print job.

The printer atribute specifies the printer to be used in the print job.

The printerType attribute specifies the printer group to which the printer
belongs. (not available yet)

Note: There can be multiple cardDocument elements with different attributes
and elements for the handling of multiple files and printers.

Within the cardDocument element we can specify the data to send to each
item in the .card document design by using item elements.

Besides the value to be sent to the item, each item element contains an id
property and a type property.

The id property is used to specify the item in the card design to which we want
to send the data (read more in chapter 4.4.1 - ltem).

The Item IDs sent to the Web Print Job must match the IDs of the items on the
.card document file that is to be printed.

The type property specifies if the item we are trying to send data to is a text
item or an image.
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When sending Images to the Web Print Server they should follow the Base64
encode scheme (read more here).
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Appendix B.2.3 - Web Print Job Sample

O Below is a sample of a completely formatted Web Print Job data to be sent
to the Web Print Server:

This follows a strict structure that must be followed when sending the print job
information to the server.

You can see an in depth explanation of each element and property of the XML
structure in Appendix B.2.2 - Print XML Structure

<?xml version="1.0" encoding="utf-8"?>
<Bodno xmins="http://tempuri.org/wpsRequest.xsd">
<login>
<name>ADMIN</name>
<password>admin</password>
</login>
<cardDocument filename="example.card" printer="Microsoft XPS Document
Writer">
<item id="NAME">RUI FARIA</item>
<item id="ADDRESS">FUNCHAL</item>
<item id="PHOTQO" type="image">
iVBORWOKGgoAAAANSUhREUgAAAFoAAABWCAIAAADACBYUAAAAAX
NSROIArs4c6 QAAAARNQU1BAACX\njwv8YQUAAAAJCEhZcwAADsMAAAT
DAcdvgGQAAANUSURBVHhe7Zq9TOtAGMb7rzB07tC5UvdKnUEW\nF2UvZ
e/HjphYSrsw8SHBFIhUJKRQOYyGRwpSBwWMSSbEZtI/VVXPOe7 Tvb5/SSvIo+
my/ivnX/xnX10\nnj3f\WjDGmA7CdBCmgzAdhOkg TAdhOgjTQZgOwnQQpoM
WHYTpIEWHYTol00GYDsJOELVOVNx+sXKO\ntPIrowLrp2ug2phWe1U1DgQff
L3zSIUrRRUdsICT+f3Q+1MvBzd7gjLAWcnhgsHAUASDVJVDKK3j\ny9mnOe
Nleq4d98uMVRx1IEUV91JCB3x3+ifSW6RgrqleSECk4EopNX1CdcBF/dnhp
mkdCC6Tt7tv\inVC95hOpowgUyAR3IYD QIXEqCdNRf3vlyGROIprngKBO/Dsw
9KRk7w8eh6gt07871cOy46138O0r5Anbku9qlGLzPFhnvcerqRR1Fzcd1VfLn4dx
Xe+wej289nH5¢cNF9akJA4kffrz3XIneudxHB7qRSINZ2\nva5V 787 +G5kcFkpe
BT+hOcHHrgkkpNO/1g1ToSChR8TXzZVWeHQUIK6502gULEwyS053+aiuQ7
VM\nCpy2jdJjOiimg2I6KKaD YjoopoNiOiimgzKnOgajgYySM486Wu1VGaKT
BvesgmUiFOWS5EZyOaq9hnUQc2hzgrdF2Kg5u9vDkyjvedenlb 1k/XpIPYGYxu
VV8uyenwfsOV4333A5LTIdVjp3t3rirKZC50\nDB+HgS +rZI8Hloxov8JNuw7M
kVI/5¢c+sDIiwUeB5Txb3Mmg4sE/NXu63201U2kKnRgct+8+dGHsuH\ni6 D +y/2
pOYGRqJZNUF1HQ7+zSHUNSego2BE 1ND6p7iQJHStHSzK criQ89pZF SjtJ
QgeQ4eSk0z8J\nf8gJQeo6SUUHNs4yosJg63Vx3wOHH]NXHynnJBUAXfOIT
mBQIQXkmJINUdIBO/1gGF TvuRJMD ThLS\ngcd+PPPKuKIm/K9yCekA+Brz
[IRRJ9OgA8BI9GtkinUAZzJpvI19IgDEYIWuUHA|dI7Brrz53ew5Wq\nDPLuU6+511
ARVdIzBJhK7SajBdrMs+F TeixnUNoS97XJuAC 1dMwepoMwHYTpIEwHYTol
00GYDsJO\nEKaDMB2E6SBMB2EG6CNNBmMA7CdBCm4wlibC38Bnj6GloLN
WKIAAAAASUVORKSCYII=\n
</item>
</cardDocument>
</Bodno>

© 2018 Bodno



Appendix B - Advanced Print Operations 217

Appendix B.2.4 - Sample Files for the Web Print Server

Contact us (Software@Bodno.com) to receive a sample application to send the
print job to the web print server.
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Appendix B.2.5 - Database Communication
Each Bodno document can have a design associated to a database.

Bodno has the ability to save all the data printed using the web print sever
(using a form or a web-based platform that retrieves an XML file).

If no specific settings are applied regarding database connection (as
described), what happens is the following:

o If the folder [PRINT] exists in the following location - C:/Users/Your
Name/AppData/Local/Bodno/PRINT Bodno will save the data in a SQLite
database in the folder.

e If not, it will look for the folder [DATABASE] and if it exists it will save the
SQLite database there.

o If [DATABASE] folder doesn’t exist, it will save the SQLite in the C:
\Users\Your User\AppData\Local\Temp).

To specify a custom database connection set the following settings in the
[PRINTING] section of the Bodno.conf file:

Setting  |Description

driver  [The name of the database driver (if left empty, the default
printing.sqlite database mentioned above will be used). The possible
values are:

QPSAQL - PostgreSQL

QMyYsQL - MySQL

QOCI - OCI (Oracle Call Interface)

QODBC - ODBC

QDB2 - DB2
QTDS - TDS
QSQLITE - SQLite
QIBASE - iBase
database [The name of the database
host The address of the database server
port The port of the database server
user The user name to use when connecting to the database server

pass The password to use when connecting to the database server
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Appendix B.2.6 - Print Job Status Request

As print jobs are sent to the Web Print Server to be printed, they are attributed a
print job id. This id can later be used to request the current status of the print
job.

This can be achieved with a print job status request.

The print job status request follows the same norms as a regular print job, but
instead of sending the cardDocument element, a getJobStatus element is sent
with a printJobld attribute containing the ID of he print job for which the status
is to be returned.

Upon receiving a print job status request the Web Print Server will return a
response (read more on Appendix B.2.6 - Print Server Response )

Below is a sample of the XML structure of a Print Job Status Request which will
return the status of the print job with the ID 5 as specified by the printJobld
element.

<?xml version="1.0" encoding="utf-8"?>

<Bodno xmlns="http://tempuri.org/wpsRequest.xsd">

<login>
<name>ADMIN</name>
<password>admin</password>

</login>

<getJobStatus printJobld="5"/>

</Bodno>
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Appendix B.2.6 - Print Server Response

Upon receiving a print job status request (see more in Appendix B.2.6 - Print
Job Status Request) the Web Print Server will return a response which can be
parsed by the user application.

The response will return an Bodno element.

This element will contain a jobStatus element with a status message of the print
job.

The jobStatus element will also contain two attributes:

The printJobld attribute specifying the ID of the print job to which the response
refers.

The status attribute specifying the current status of the print job.
Status attribute can be one of the following vales:

CREATED

PENDING

PRINTING

DELETED

ERROR

The Bodno element will also have a status Message element, containing a
detailed message regarding the status.
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Appendix B.3 - AutoPrint

@ One of the advanced print features you can use with Bodno is the ability to
automate print jobs and use external applications to run custom print jobs. This
feature is called AutoPrint.

For these purposes Bodno allows you to use the Windows Command Prompt to
run print jobs you have previously prepared.

The possibility to use the Command Prompt to run customizable print jobs allows
you to create .bat files with your custom settings and run those .bat files
whenever you need.

You can also use external programs to run custom print jobs, either by running
the Bodno AutoPrint commands, or by running a previously saved .bat file.

To work with AutoPrint, the card you are going to use must be previously saved
with your printer settings configured.

Appendix B.3.1 - AutoPrint Commands

@ Below are the commands used to interact with Bodno through the command
prompt:

IP - Print

IFILTER:"data" - Conditional Print Filter

/CONTINUOUS:seconds - Continuous printing with seconds delay
ISHOWPRINTDIALOG - Always show Print Dialog Box

IDBFILTER:"Filter" - Where "Filter" is the equivalent to a SQL WHERE clause

ISAVE:"optionalFileName" - Saves the document opened in the command line
applying all changes made by Print or DBFilter.

If optionalFileName is specified, then the card document will be saved with the
new name.

For example:
/ISAVE - saves the document with the current file name.

ISAVE:"D:/Tickets/newCard.card" - saves the document with the new file name
Using the Save command with a filter allows you to preview the card fields filled
with data that meets the determined conditions before printing.

/EXIT - Forces Bodno to Close & Exit after printing.

The syntax for the /P print command to be used from Run or Command Prompt
is:
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"c:\Program Files\Bodno\Bodno.exe" "c:\cP Test.card" /P

where:

"c:\Program Files\Bodno\Bodno.exe" - Bodno's executable file location
"c:\cP Test.card" - card file location

/P - print command

© note: Bodno's executable file location may vary depending on your operating system
and the location you selected when installing Bodno.
The card file location is where you saved your Bodno .CARD document.

Appendix B.3.2 - AutoPrint with Command Prompt and Windows
Run

@ AutoPrint commands can be run directly either from the Windows Run
dialog box, or from the Windows Command Prompt.

To run an AutoPrint command from the Windows Run dialog box, open the
dialog box through the Windows Menu Start>Run type the AutoPrint command
in the dialog box and click the OK button:

=== Typethe name of a program, folder, document, or Internet
resource, and Windows will open it for you,

"ciheP Test.card" /P4

| QK || Cancel || Browse... |

To run an AutoPrint command from the Windows Command Prompt, open the
command prompt through the Windows menu Start>Accessories>Command
Prompt. And type the AutoPrint command in the Command Prompt window:

All rights reserved.
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Appendix B.3.3 - AutoPrint Batch File

@ AutoPrint commands can be stored in a batch file (.bat) for later use. This
way you can create as many batch files as you like, each with it's custom
settings, and run your desired file with the desired settings whenever it's
needed.

You can create a batch file in any regular text editor like Notepad.
Simply create a new text document. Type the AutoPrint commands you want to
run and save the file with the .bat extension.

Mame Date modified Type Size
| [E cPoatchfile || 30-12-2013 15:51 Windows Batch File 1 KB
= = =
| cPbatchiile - Notepad = B8 =
File Edit Format VMiew Help —
nc TNPTOQram Files Nl -exe" “gih..Test,.card” /P =
'
r B
7| Save As [
L |l « Local Disk (C:) » cpbatch - |*,~ || Search cobatch 2
File name: | 3 | -
p— Save as type: | Text Documents (*.bad) -
& Browss Eolders Encoding: [AN‘SI '] [ Save l | Cancel |

You can then run the .bat file directly, or through an external program such as
the Windows Task Scheduler.
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Appendix C - Encoding

@ The multiple types of encoding available in Bodno provides the best flexibility
when working with multiple card types.

To ensure a good knowledge base, in this chapter we will further develop the
topic of encoding, addressing each type of encoding and how to perform it
within Bodno.

0 For testing purposes, we recommend disabling Front and Back printing on the print
window (menu File>Print) before printing.

Print Operations

Print Front
] Print Back_
L ¥ Magnetic Encoding

Appendix C.1 - Magnetic Stripe

@ Magnetic encoding is a contactless type of encoding performed on the
magnetic stripe (Magstripe) of a magnetic card. Bodno supports both High
Coercivity (HiCo) and Low Coercivity (LoCo) magnetic cards.

There are up to 3 tracks on magnetic cards: Track 1, Track 2 and Track 3
Each Track supports a specific data type and size.

Track 1 - 80 Alphanumeric Characters
Track 2 - 40 Numeric Characters
Track 3 - 110 Numeric Characters

When a magnetic card type is created, Bodno displays a visual representation
of the Magstripe on the Card Back view. This allows you to individually select
each Track and edit the data to be encoded directly through the card design
view.

You can access it by clicking the View Card Back button, or through the menu
View > Card Back.
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Appendix C.1.1 - Macros / Sentinels

© When encoding data into a Track the data must follow a specific set of
formatting rules. These are what determine which Track is being written and
what data is to be written.

To do this, encoders use a set of characters named Sentinels which determine
where the data to be encoded starts, where it's separated and where it ends.

Start Sentinel (generally '%") marks where the data to be encoded is going to
begin.

End Sentinel (generally '?') marks where the data to be encoded ends.
Field Separator (generally 'V') separates different fields within a track.
ex: %Example*Text?

Where:

%' is the Start Sentinel.

'Example’ is the first field of data to be encoded on the current track.
"M is the Field Separator.

'Text' is the second field of data to be encoded on the current track.

'?' is the End Sentinel.

Bodno simplifies the process by using Macros: an array of Sentinel presets
for several manufacturers, making changing Sentinels as simple and easy as a
click (see more on Appendix C.1.5).
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Appendix C.1.2 - Adding Data to a Track

© Tracks in magnetic cards can work as easily as any other item in Bodno
when it comes to adding data. Simply double click the data track you wish to
encode, input the data in the textbox and click the Close button. The change will

be immediate:

This allows you to quickly add information into a magnetic card without any
previous knowledge on magnetic encoding.

Appendix C.1.3 - Adding a Database Source to a Track

© When working with databases, having the versatility to add a database item
to a Track is fundamental.

As with any item in Bodno, each Track contains its own set of properties which
can be used for advanced encoding operations.

To add a database source to a Track:
1 - Select the Track in the Card Back view.

2 - On the Source tab, to the right, change the Source type to Database
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3 - Select the Table where the database data is stored.

4 - Select the Column which contains the data to be encoded.

Database
Table
Employee

Column

First Name

Font auto adjust

Mewver

Concatenation

All changes are immediately visible in the Design View:

Appendix C.1.4 - Concatenation With Databases

© Concatenation allows you to stack up to three database fields within the
same Track. This is allows for a much more dynamic and space efficient data
generation when working with magnetic tracks.

To use Concatenation on a Track select the Track, on the Track Properties
select the Source tab and click the Concatenation button.
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The Concatenation pop-up provides the following options:

Data Prefix allows you to customize the text prefix that appears on the currently
selected track.

Ignore on print disables or enables encoding the Data Prefix.

Data Suffix allows you to customize a text suffix that appears on the currently
selected track.

Ignore on print disables or enables encoding the Data Suffix.
Concatenate database columns enables or disables Concatenation.

Column Prefix adds a text prefix to the data obtained from the selected data
column.

i Usually used for the Field Separator Sentinel

Column selects the database column from which to obtain the data.
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[ Database

Table

[ Employee

Column

[ Employee Id

Font auto adjust

[ Mever

Data Prefix

\TRACKI: | Ignore on print

Data Suffix

| | [E Ignore on print

Concatenate database columns

Column Prefix
& |

Column

[ First Name | »

Column Prefix

| Fay

Column

[ Last Name | * l

Column Prefix

| Fal

Column

[ Extension | l

H Cancel |
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Appendix C.1.5 - Editing Magnetic Macros / Sentinels

@ Different encoder manufacturers use different Sentinels. To simplify
managing sentinels Bodno provides several Macros with preset Sentinels from
several manufacturers.

You can change Macros through the Bodno menu File > Print Settings >
Print Options > Magnetic Encode > Macros and select your encoder/printer
manufacturer.

Print Options

- Antialiasing -
- Composite black replacement

4 Magnetic Encode
4 Macros

i Ewolis
| CIAAT -
.1Datacard
<Ewolis
{Fargo
GLADIO
- Ch i
4 AdvV| g A Smart
* Rd Jawvelin
- Fli Magicard
=l Misca o L

To manually configure Macros open the Bodno menu File > Print Settings >
Print Options > Magnetic Encode > Macros and select User Defined.

This will allow you to manually type the Start Sentinel and End Sentinel as
shown below. All 3 Tracks must be manually set.

Print Options

» Composite black replacement *
4 Magnetic Encode
4 Macros

User Defined

* Font
4 Track 1
4 Begin
%
4 End
?
s MdLk £
-Track 3
: Character encoding -
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Appendix C.1.6 - Script Encoding

@ Bodno also allows you to manipulate Track data through Scripts. This
powerful feature allows for even more advanced operations to customize your
encoded data to its full potential.

In Bodno each Tracks has a unique ID. Namely ISOTRACK1, ISOTRACKZ2,
and ISOTRACKS3 for Track 1, Track 2, and Track 3 respectively.

The data on this item can be manipulated through scripting as with any other
item.

© The encoded data must still follow each Track's data type (see more on
Appendix C.1 - Magnetic Stripe).

To create a Script click an empty area of the card design and select the Script
tab in the Properties Dock..

(i Scripts can also be added to an item by selecting it and clicking the Script tab in
the properties Dock.

On the Script tab you can select when the script should executed and on the
text box, write the script.

Ex item.ISOTRACK1="Example Text"

Before Printing

itemn . |SOTRACK]L ="Example Text"

Background

P,
w
]
e}
I
]
(=]

i' Script | Database Find | Database Filter

Script | Output 2]
Example Text
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Appendix C.2 - Contact Encoding

233

@ Contact encoding in Bodno is done with the Encode Operations window in

the Encode View. Here you can develop your customized encoding operations

for all the supported contact Card Types.

This allows you to manipulate the data stored in your Card, the data in the Card

Design Items and the data stored in your database, if connected to one.

The code varies with each Card Type. Bodno comes with sample code for the
supported Card Types designed to get you familiar with the basic operations of

each Card Type.

Below is the sample code of an I2C script.

Contact encoders -DMNiKET CardMan 5x21 0 ] [g] [ﬂ__]

card.hasnullUiDs=true:
card.waitForPresent{®#12C");

I2CwIitelD " e E
|2C write(10,"6D6F7265207468616E20616E2061706C69636174696F6E", "hex”);

logli2C.read{0 .10).toHex {});
log{12C.read(10,23).toutfa());

[2C.read(10.23).toutfa():

Contact | Output
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Appendix C.3 - Contactless Encoding

©® Contactless encoding in Bodno is done with the Encode Operations
window in the Encode View. Here you can develop your customized encoding

operations for all the supported contact Contactless Types.

This allows you to manipulate the data stored in your Card, the data in the Card
Design Items and the data stored in your database, if connected to one.

The code varies with each Card Type. Bodno comes with sample code for the
supported Card Types designed to get you familiar with the basic operations of

each Card Type.

Below is the sample code of a Mifare script.

Jf Read and Wite to a Block of the card

J wirite to HEX in sector X block v
Jimifare write(X,Y,"S4657374207772697465000000000000% "HEX"):

JI from the connected Database
Jimifare.write (XY, currentRecord["Hire Date"].toString());

}f Simple text write
fimifarewrite(X,Y,"Test read");

JI to write to the trailer use
jimifare writeTrailler{ X, "FFFFFFFFFFFFFFO 7806 9FFFFFFFFFFFF");

Jf to read a Block without converting it
Jimifare.read(X.Y):

JI Read with conversions
Jimifare.read(X,Y).toHex();
fimifare.read(X.Y).toString();
fimifare.read(X,y).toUTFE();

/I To save the read data to a field in a Database use:
ffeurrentRecord COLUMNMAME=mifare.read(X.Y):currentRecord.save();

. i S S T il I —

Contactless encoders | OMNIKEY CardMan 5x21-CL 0 I :Q

__FFl

Contactless | Output [
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Appendix D - Barcodes

€@ Barcodes are a staple of today's industry and Bodno follows through in this
feature as well.

Supporting 1D and 2D barcodes libraries with various customizations allows for
a wide application area.

To create a barcode simply click on the New Barcode or New 2D Barcode
button on the Design Toolbar and then click-drag the new barcode to the size
you want.

| &8

Appendix D.1 - 1D Barcode

© A 1D Barcode is the most common barcode type also known as a Linear
Barcode.

© To create a 1D Barcode click the New Barcode button in the Design
Toolbar or through the Bodno menu Tool>Barcode.
You can then click-drag to place the new barcode with the desired size.

To customize the barcode, select it and click the Barcode separator in the
Properties Dock.

The following options are availlable:

Symbology lets you select the symbology the barcode should use.

Barcode color lets you change the color of the barcode.

Module width lets you customize the width of the module.

Bearer bar customizes the positioning and shape of the barcode bearer bar.
Bearer width customizes the width of the Bearer Bar.

Quiet zone customizes the size of the quiet zone.

Human readable customizes or disables the barcode caption text.

Font customizes the size of the caption text.

CheckDigit enables or disables the Check Digit.
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| Code 2 of 5

Barcode color

| lRGE(0,0,0) |

Position

Module width

| Auto |

Bearer bar

| Mo bearer bar

Bearer width

=
C
@
£
C

S

=L

0.75 mm

Quiet Zone

|Dmm

Human readable

| Eelow

Font

Outline

| Mormal

CheckDigit

|Nune

J' Barcode

Appendix D.2 - 2D Barcode

@ A 2D Barcode also know as a matrix code, is an advanced barcode type
which can hold more data per area.

© To create a 2D Barcode click the New 2D Barcode button in the Design
Toolbar or through the Bodno menu Tool>2D Barcode.

You can then click-drag to place the new barcode with the desired size.

To customize the barcode, select it and click the Barcode separator in the
Properties Dock.

The following options are available:

Symbol format changes the symbol format of the barcode.

Barcode color changes the color of the barcode.
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QRCode Format changes the barcode encode system.
Module Width changes the width of the barcode.

Mask changes the barcode mask.

EC Level changes the error correction level.

Size/Version changes the barcode size/version.

|' QR-Code

Barcode color

| MRGB(0,0,0) -

Fosition

Code Page

|. Default

QRCode Format

|_ Standard

Module width

o
=
a
=
|
=

=
=L

| Auto

Mask

| Standard

EC Level

| Medium

Outline

Size/Version

|' 21 x 21/(vs 1)

[Barcode A

Appendix D.3 - Database Generated Barcodes
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@ Bodno's barcodes also supports having database items as the data source.
This means Bodno can dynamically generate barcodes using the data from an
existing database.

As with any item in Bodno, each Barcode contains it's own set of properties
which can be used for advanced barcode generation.

To add a database source to a Barcode:

1 - Select the Barcode in the Card Design view.

2 - On the Source tab, to the right, change the Source type to Database
3 - Select the Table where the database data is stored.

4 - Select the Column which contains the data to be written on the Barcode.

| Database
B Table
o (
-T‘g | Employee
&  Column
| First Name
= Data Prefix
o
E
C e
o . | [ ignore on print
= :
C Data Suffix
o
£
o
i
o [ Ignore on print
[¥] Concatenate database columns
w
= Column Prefix
=
=
O
Column
i | Last Name
@ Column Prefix
e .
¥ Extension:
o
= (glumn
: Extension

Column Prefix

lH]
[+
=
o
o
w

Column

(Mot Used)

oK Cancel
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Concatenation allows you to stack up to three database fields within the same
Barcode. This is allows for a much more dynamic and space efficient data
generation when working with barcodes.

To use Concatenation on a Barcode click the Concatenation button on the
Source tab.

The Concatenation pop-up provides the following options:

Data Prefix allows you to customize the text prefix that appears on the currently
selected track.

Ignore on print disables or enables encoding the Data Prefix.

Data Suffix allows you to customize a text suffix that appears on the currently
selected track.

Ignore on print disables or enables encoding the Data Suffix.
Concatenate database columns enables or disables Concatenation

Column Prefix adds a text prefix to the data obtained from the selected data
column.

Column selects the database column from which to obtain the data.

Appendix D.4 - Script Generated Barcodes_2

@ Bodno also allows you to manipulate Barcode data through Scripts. This
powerful feature allows for even more advanced operations to use your
barcodes to their full potential.

In Bodno the data on this item can be manipulated through scripting as with any
other item.

© The encoded data must still follow each Barcode's format rules.

To create a Script click an empty area of the card design and select the Script
tab in the Properties Dock..

O Scripts can also be added to an item by selecting it and clicking the
Script tab in the properties Dock.

On the Script tab you can select when the script should executed and on the
text box, write the script.

O Ex in the example below the QR code being used was given the ID QR.
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Wwhen ltem Double-Clicked

item.QR.data="TEXT "

Script | Output @

Result:

| When ltem Double-Clicked [+

item.QR.data="TExXT "

Script | Output @
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Appendix E - Link Image to DB Field

© Pictures and images are a recurring element of ID cards. When connected
to a database Bodno allows you to quickly set up a database field as a
source for images on your computer.

To set a database field as a link to an image file follow these steps:

1 - Locate the database field that contains the name of the picture files. In the
example image below, the field name is Image File Path:

2 - Right click the database field to open it's Properties menu and change
change the Data Type to Point to Indexed Image.

Image File Path Properties
Data Type

| Text Line |_|
Eq Text Line
Text Box
Point to Indexed Image
Value
Database Counter ncel
Integer Value
Date
Time
Date and Time
List
Database list

3 - Before closing the Properties menu, click the "..." button to the right of the
Data Type drop down list.

4 - On the Indexed Image Properties menu in the Images Folder type the path
to the folder which contains your images.

Alternatively, click the "..." button to the right of the Images Folder path and
browse to your images folder.
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Image File Path Properties
Data Type

| Text Line I D

Eq Text Line

Text Box

Point to Indexed Image
Value

Database Counter ncel
Integer Value
Date

Time

Date and Time
List

Database list

When you're done. Click the OK button on the Indexed Image menu. Then click
the OK button on the Properties menu and finally click the Database refresh
button as prompted.

When refreshed, if correctly configured and the database field contains valid
image paths, the database field will now show the images from the folder.
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